WordPress.org

Forums

wp_get_current_user() undefined after 2.2 upgrade (12 posts)

  1. dan13l
    Member
    Posted 8 years ago #

    Everything was fine prior to the upgrade, not I get

    "Fatal error: Call to undefined function wp_get_current_user() in /home/15108/domains/istherefood.com/html/wp-includes/capabilities.php on line 446"

    When accessing wp-admin after moving to 2.2. I've tried reuploading the files, now going to try deleting the contents of the plugins folder (can't disable, can't access admin console).

  2. whooami
    Member
    Posted 8 years ago #

    that function is defined inside wp-includes/pluggable.php ..

    You might want to re-upload a fresh copy of that specific file and see if that helps.

  3. halinagold
    Member
    Posted 8 years ago #

    I have a similar problem

    I upgraded to 2.2 the usual way. Then, when I started activating plugins I got

    Call to undefined function wp_get_current_user() in ...\wp-includes\capabilities.php on line 446

    I can view the blog, but I can't get in to admin!!

  4. halinagold
    Member
    Posted 8 years ago #

    OK, I managed to go back. Here's how:

    1. deleted WP 2.2 from server
    2. uploaded WP 2.1.3
    3. went to .../wp-admin/
    Got the message: your database is out of date and the system suggested that I upgrade
    4. so clicked on upgrade (hoping for the best...)
    5. "Upgrade" (which really was a downgrade back to 2.1.3) successful
    6. I'm in Admin again

    So will try to upgrade to 2.2 again - in a couple of days! (I want to see if there are general problems with this upgrade or what?)

  5. davideaves
    Member
    Posted 8 years ago #

    I'm getting the same error, but I tried halinagold's solution and it didn't work...

    Everything was fine until I started activating the plug-ins, then it crashed. Now I can't login at .../wp-admin

    Any suggestions.

  6. nexthought
    Member
    Posted 8 years ago #

    I am also getting the same wp_get_current_user error. I tried halinagold's solution and can get to the "Your database is out-of-date. Please upgrade." message. However, when I click "upgrade", it just reloads the same page and nothing seems to happen.

  7. edelen
    Member
    Posted 8 years ago #

    I found the problem.

    If you're using a plugin or widget that must be installed in the folder of the old widget plugin, that plugin will break everything.

    Now that WP 2.2 has widgets built-in there's no need for the old widgets plugin. However, a few plugins/widgets are built to be installed in the same directory as the "widgets.php" file. Now that that file has been moved out of the plugins folder, problems arise.

    Your problem plugins may differ, but I broke my blog with the King Text and King Links plugins/widgets. They must reside in the old widgets folder in the plugins folder. Now that widgets are incorporated in WP 2.2 and no longer a plugin, those two break and will take your blog down with them.

    Fix: Copy your old widgets folder to your local hard drive as backup. Delete the widgets folder from your blog's server. (If you haven'y upgraded your database, do so.) Reload your dashboard. Now you should be fine.

    Sadly, the King widgets series (which powers my entire sidebar) needs an update to work with 2.2 from what I can see. No updates exist at the time of this writing. Check the site here:

    http://www.blog.mediaprojekte.de/

  8. swingcheese
    Member
    Posted 8 years ago #

    thanks edelen,
    it's the solution, great...
    bests,
    philippe

  9. Aryxmyth
    Member
    Posted 8 years ago #

    This worked perfectly for me as well. All I did was go in and delete my widgets folder (after backing it up). When I went to my site I got a message saying it needed to upgrade. I continued and from that point on the site worked just fine. Thanks for posting the fix!

  10. eeeoa
    Member
    Posted 8 years ago #

    I have the same message :

    Fatal error: Call to undefined function: wp_get_current_user() in /mnt/138/sdb/0/d/eeeoa/wordpress/wp-includes/capabilities.php on line 446

    even if I have fully deleted the folder wp-contents/widgets...

    Is there a solution...? Thanks:)

  11. jaero
    Member
    Posted 7 years ago #

    I fixed it, for the most part.

    Line 25 of king-text.php is:

    include_once(widgets.php');

    Before you upload the file to your plugins folder, get rid of that line of code. I imagine the redundancy of including that file (which doesn't work even if you direct it to the correct wp_includes folder) is what's breaking it.

    I deleted that line, uploaded the php file, activated the plugin, and it works. There is however an ugly little bug when editing the widget settings, where the settings background cuts off - but on the blog itself, it seems to work fine.

  12. Gwyneth Llewelyn
    Member
    Posted 7 years ago #

    Note that there is a include_once('widgets.php'); on line 562 too; removing it as well seems to make the plugin work fine for me under 2.3.2.

Topic Closed

This topic has been closed to new replies.

About this Topic