• Resolved B_Dark

    (@b_dark)


    I eneble my WP_DEBUG, and i got this notices on my front,admin & error log on my wp 3.5 multisite:

    Notice: Undefined index: paged in /home/site/public_html/wp-content/plugins/top-10/admin.inc.php on line 379

    Notice: Undefined index: limit in /home/site/public_html/wp-content/plugins/top-10/admin.inc.php on line 380

    Notice: Undefined index: exclude_pages in /home/site/public_html/wp-content/plugins/top-10/admin.inc.php on line 381

    Notice: Undefined index: daily in /home/site/public_html/wp-content/plugins/top-10/admin.inc.php on line 382

    Notice: Use of undefined constant ald_get_the_post_thumbnail – assumed ‘ald_get_the_post_thumbnail’ in /home/site/public_html/wp-content/plugins/top-10/ald-framework.inc.php on line 10

    Notice: Use of undefined constant ald_excerpt – assumed ‘ald_excerpt’ in /home/site/public_html/wp-content/plugins/top-10/ald-framework.inc.php on line 69

    Notice: Use of undefined constant ald_save_page_ID – assumed ‘ald_save_page_ID’ in /home/site/public_html/wp-content/plugins/top-10/ald-framework.inc.php on line 93

    Notice: Use of undefined constant custom_CSS – assumed ‘custom_CSS’ in /home/site/public_html/wp-content/plugins/top-10/top-10.php on line 244

    http://wordpress.org/extend/plugins/top-10/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Ajay

    (@ajay)

    Can you try editting line 379 and tell me if the first error goes away?

    $paged = (isset($_GET['paged']) ? intval($_GET['paged']) : 0);

    For Line 10 of ald-framework.inc.php could you please edit it:

    if (!function_exists('ald_get_the_post_thumbnail')) { function ald_get_the_post_thumbnail($args = array()) {

    If these two points fix the errors, the others are exactly similar fixes.

    I can put through these fixes in the next version.

    on line 379 is <?php tptn_admin_side(); ?> you whant to replase with $paged = (isset($_GET[‘paged’]) ? intval($_GET[‘paged’]) : 0); right?

    so after your suggestions
    on front of site shows me this

    Notice: Use of undefined constant ald_excerpt – assumed ‘ald_excerpt’ in /home/site/public_html/wp-content/plugins/top-10/ald-framework.inc.php on line 69

    Notice: Use of undefined constant ald_save_page_ID – assumed ‘ald_save_page_ID’ in /home/site/public_html/wp-content/plugins/top-10/ald-framework.inc.php on line 93

    Notice: Use of undefined constant custom_CSS – assumed ‘custom_CSS’ in /home/site/public_html/wp-content/plugins/top-10/top-10.php on line 244

    and on /wp-admin/edit.php?page=tptn_manage

    Notice: Use of undefined constant ald_excerpt – assumed ‘ald_excerpt’ in /home/site/public_html/wp-content/plugins/top-10/ald-framework.inc.php on line 69

    Notice: Use of undefined constant ald_save_page_ID – assumed ‘ald_save_page_ID’ in /home/site/public_html/wp-content/plugins/top-10/ald-framework.inc.php on line 93

    and on right-side of plugin stats the code..
    $paged = (isset($_GET[‘paged’]) ? intval($_GET[‘paged’]) : 0);

    Plugin Author Ajay

    (@ajay)

    I’ve released a new version that should take care of these errors. Could you please check that new version and let me know if you still see this behaviour?

    no 🙂 you are the boss!! 😉 Thnax a lot for the asap fix!!
    Happy holidays!!

    Plugin Author Ajay

    (@ajay)

    Thank you and happy holidays to you as well 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WP_DEBUG Notices’ is closed to new replies.