Support » Plugin: Genesis Super Customizer » WP_DEBUG messages upon activation

  • I’ve never heard of or tried this plugin before, but it looked cool.

    Upon activating, I saw these WP_DEBUG messages in wp-admin above the Plugins page:

    Notice: Undefined index: default in /wp-content/plugins/genesis-super-customizer/public/class-gsc-base.php on line 182

    Notice: Undefined index: default in /wp-content/plugins/genesis-super-customizer/public/class-gsc-base.php on line 182

    Notice: Undefined index: default in /wp-content/plugins/genesis-super-customizer/public/class-gsc-base.php on line 182

    Plugin deactivated and deleted for now…

    https://wordpress.org/plugins/genesis-super-customizer/

Viewing 4 replies - 1 through 4 (of 4 total)
  • This only happens when you have set WP_DEBUG to true. But I like to work with this setting on my local development installation and so I deacivated this plugin.

    Plugin Author Mario Giancini

    (@mario-giancini)

    Hi Clifford Paulick,

    Do you remember which other plugins you were using at the time? Where you using the Genesis parent theme or child theme?

    Thanks!

    Thread Starter Clifford Paulick

    (@cliffpaulick)

    Can’t remember. Sorry.

    I had the same notices. To get rid of it edit /wp-content/plugins/genesis-super-customizer/public/class-gsc-base.php and around line 175 change from:

    if( $this->settings_field !== 'genesis-settings' ) {
            foreach( $this->mod_settings as $mod => $settings ) {
              self::$default_settings[$mod] = $settings['default'];
            }
          }

    to

    if( $this->settings_field !== 'genesis-settings' ) {
            foreach( $this->mod_settings as $mod => $settings ) {
              self::$default_settings[$mod] = isset($settings['default']) ? $settings['default'] : '';
            }
          }
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘WP_DEBUG messages upon activation’ is closed to new replies.