WordPress.org

Support

Support » Plugins and Hacks » Eazyest Gallery » [Resolved] WP_CONTENT_DIR not honored

[Resolved] WP_CONTENT_DIR not honored

  • hi!

    I’m missing the suport of WP_CONTENT_DIR and/or WP_CONTEN_URL.

    my setup of wordpress is that its located in /usr/share/wordpress, that’s also my DocumentRoot in apache.
    but, all the content is located in /srv/www/wp-content/<domain>/. therefore I’ve Alias /wp-content /srv/www/wp-content/<domain> in apache. and somewehere else define('WP_CONTENT_DIR', '/srv/www/wp-content/<domain>');. it’s working fine with wordpress’ own media library.

    Eazyest Gallery is showing me more or less the correct gallery folder as ../../../srv/www/wp-content/<domain>/gallery/. uploading some pictures into the gallery is successful.

    but the main problem is that (not only) thumbnails are linked as http://<domain>/srv/www/wp-content/<domain>/gallery/<folder>/_cache/<picture>-150×150.jpg

    seems to me that WP_CONTENT_DIR is not honored in any case.

    what I would have awaited is that the gallery folder in the settings is just “gallery” and with the help of WP_CONTENT_DIR you get the path in the filesystem where the gallery is located. you can also use WP_CONTENT_URL for generating the correct url (btw, I have set this also in my config).

    do you see any chance to get this into your plugin.

    gre3tings, Klaus

    http://wordpress.org/extend/plugins/eazyest-gallery/

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] WP_CONTENT_DIR not honored’ is closed to new replies.
Skip to toolbar