Support » Installing WordPress » “wp_categories’ doesn’t exist” error in database wp 2.3

  • WordPress database error: [Table ‘minimal_basedatos.wp_categories’ doesn’t exist]
    SELECT cat_ID, cat_name FROM wp_categories

    Hi, I have this error in my k2 comfiguration section when i updated to wordpress 2.3, also without any plugin activated.

    Whats the problem?.

Viewing 15 replies - 16 through 30 (of 40 total)
  • I am still having a huge problem with my blog since I tried to upgrade to 2.3.

    Before the upgrade I backed up everything and then used subversion to get 2.3. I saw the database errors described. I decided to roll back, so I deleted the new directory and restored my old directory. I’m back on 2.2.2 (so my admin panel assures me), but now I’m still getting error messages at the top of every post


    WordPress database error: [Table ‘payless_gartenbergcom.wp_post2cat’ doesn’t exist]
    SELECT post_id, category_id FROM wp_post2cat WHERE post_id IN (676)

    as well as error messages for my blogroll

    WordPress database error: [Table ‘payless_gartenbergcom.wp_categories’ doesn’t exist]
    SELECT * FROM wp_categories

    Any ideas on how to get the old version of WordPress working properly again? I’m giving up on 2.3 for now, but would like to have a functioning blog without tons of errors. Thanks.

    I wound up using phpmyadmin to add the wp_categories table back. It wasn’t picky about field names or descriptors and that has gotten rid of the message. It does not appear to be affecting my blogs in anyway other than getting rid of the message.

    GREAT idea, thanks. I thought my database was restored, but it wasn’t. All is working fine again!

    It’s going to be awhile before I try to upgrade to the new version again.

    i found this great explanation here:
    just need to edit theme templates a little bit by replacing 3 stuffs:

    * cat_ID –> term_ID
    * categories –> terms
    * cat_name –> name

    found here

    Hi, i deactivate the google site maps plugin for solve this problem;

    Google Sitemaps 2.7.1

    there are anothers plugins with the same problems

    has anyone tried finding and replacing these terms:

    * cat_ID –> term_ID
    * categories –> terms
    * cat_name –> name

    In the Custom Query String plugin to see if it will work?

    I had a plugin that wasn’t working and after doing the replace – as suggested above:

    * cat_ID –> term_ID
    * categories –> terms
    * cat_name –> name

    I was able to get it to work – I had to change it a little bit as well – because it was calling post2cat as well – so I changed that to post2terms.

    Interesting. That was just a hunch. Glad it worked. Can anyone else verify that this is all it would take to update the Custom Query String plugin?

    I’ve got it worse than any of you I guess. I upgraded to 2.3, but didn’t disbale the plugins first. Site didn’t work anymore. It shows a ‘cannot display page’ in IE and in firefox the pages are cut off. In firefox, I could get into the admin. So i disabled all plugins, reverted to the default theme, but the problem stayed. Even worse: all sites on that dedicated server that use mysql are in problems now. They don’t work, or work half. If I use ‘top’ in the shell, I can see that mysqld just builds up and up in time. ‘ve tried a lot now (rebooted the server, restarted mysql, but nothing seems to work). So apart from my wordpress site not working, lots of other sites now don’t work either.

    If anyone thinks of a possible solution, that’d be great!

    this thread seems to have a solution for the Custom Query String problem:

    @lexthoonen – your database was updated during the upgrade. Unless your restored the old database, you’ll probably see the same problems. It’s not clear to me what the cause was. Perhaps you’ll have better luck if you introduce this as a new thread?

    I got the same problem too.
    The problem lies in the Google Sitemap plugin.
    Try disabling it and see any improvement.

    I’m using a variant of the ancient Trident theme on my blog ( ) and nothing seems to be working out when I try correcting this issue. I’m looking for the category tags as specified above but can’t find them in my index or sidebar files.

    At worst, can someone recommend a good 3 column theme that I can customize to suit this blog? 🙁 Trying to figure out the conflict is driving me crazy

    A plugin or some tags in your old theme are calling the wrong DB table.

    Check the Template_Tags section, and see if any deprecated template tag is used in your theme. I’d bet they are there. Replace them with the new ones (that say for WP 2.1)

    Moshu, THANK YOu for pointing me to that page (I tried searching for it but under the guise of how to update your WordPress theme for 2.3 — I kept getting tag support pages). This should take up the rest of my afternoon but I’m pretty sure it’s got to be a tag that has Deprecated. (I already tried deactivating all plugins, the problem still existed).

    I figure out what was wrong and it WASN’T the theme.

    I uploaded 2.3.1 via Dreamweaver MX and opted not to upgrade certain files… That lead to the conflict. The minute I re-installed by uploading ALL WP 2.3.1 files, it worked fine with no errors.

    Oh well… Thanks again Moshu

Viewing 15 replies - 16 through 30 (of 40 total)
  • The topic ‘“wp_categories’ doesn’t exist” error in database wp 2.3’ is closed to new replies.