Support » Networking WordPress » wp_1_ tables not created in new MultiSite install

  • I’m trying to set up a WordPress MultiSite following the Create a Network instructions. I have made sure to check and double-check all requirements, and have followed the instructions exactly. When I get to part 4 of Step 5, which is to log in to my site again, I get a message saying “Error Establishing a Database Connection”. I then attempt to use the repair utility that automatically shows up when I try to access /wp-admin/. After doing the repair, I get this set of error messages:

    wp_1_posts: Table 'espdesig_wrd1.wp_1_posts' doesn't exist
    wp_1_comments: Table 'espdesig_wrd1.wp_1_comments' doesn't exist
    wp_1_links: Table 'espdesig_wrd1.wp_1_links' doesn't exist
    wp_1_options: Table 'espdesig_wrd1.wp_1_options' doesn't exist
    wp_1_postmeta: Table 'espdesig_wrd1.wp_1_postmeta' doesn't exist
    wp_1_terms: Table 'espdesig_wrd1.wp_1_terms' doesn't exist
    wp_1_term_taxonomy: Table 'espdesig_wrd1.wp_1_term_taxonomy' doesn't exist
    wp_1_term_relationships: Table 'espdesig_wrd1.wp_1_term_relationships' doesn't exist
    wp_1_commentmeta: Table 'espdesig_wrd1.wp_1_commentmeta' doesn't exist

    I’ve logged into phpMyAdmin to check out the databases, and I can confirm that the default wp_* tables exist, but the wp_1_* tables do not exist. I have verified that the DB user has full privileges, including CREATE. I have even tried manually creating a new DB user instead of letting my host do it all automatically, but that didn’t make a difference.

    This is not the first time I’ve had a WordPress installation on my server, and there were some left over databases from previous WordPress installations. I thought that these might be interfering, so I deleted all old databases and DB users. I removed all WordPress files and directories so that I could make sure I’m staring fresh. And there was definitely no problem with the regular WordPress install before attempting to activate MultiSite.

    I’ve done some searching, and I have seen other people reporting a similar problem, but I haven’t seen anyone’s solution yet. Does anyone have any ideas for a solution, or know of some documentation that I can follow to overcome this issue?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Plugin Review Team Rep

    It’s not supposed to make wp_1_* tables anymore. That was only done in WPMU and as of WordPress 3.0, you start with wp_* and all subsequent sites get numbers.

    Out of curiosity, did you make your site, log in, and THEN activate multisite?

    Yes, I made the site, logged in successfully, and then started following the directions for setting up multisite. The code that was copied into my wp-config.php and .htaccess files was copied from my Dashboard > Tools > Network page.

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Plugin Review Team Rep

    You didn’t install any plugins or anything? Just logged in and went right to net=work?

    There was a Jetpack plugin installed, but it was deactivated. Other than that, it was just the Akismet and Hello Dolly plugins that come with WordPress.

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Plugin Review Team Rep

    The reason I’m asking is because none of that SHOULD happen, so I’m casting a net trying to suss out what’s ‘different’.

    I’ve yet to be able to reproduce this, but I’ll try it again…

    Go look at your database – did the network-specific tables get created or not?

    @ipstenu: Let’s eliminate all assumptions then. My host is HostMonster (I think it’s basically the same company as Bluehost). I’m using their Simple Scripts to automatically setup WordPress initially, including the DB and DB users. From there, I login to the admin page, and then begin following the instructions for creating a network.

    I had previously had a multisite set up (I think it was with version 3.0), and tht worked with no problem. I recently decided I wanted to start things fresh, which is where I’m at now. Based on that experience, I’m assuming that setting up a network is no problem on that host.

    @andrea_r: What DB tables should I look for? I can check to see if they are there.

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Plugin Review Team Rep

    I’m using their Simple Scripts to automatically setup WordPress initially, including the DB and DB users.

    HAH! That is useful! Thank you so much!

    Delete it all. Make a DB manually if you can, and install WP manually. If not, check your wp-config.php for multiple references to wp_<whatever> as your DB, and see if there are duplicate calls to $BASE in there.

    Ding ding! Yeah I’m betting it;s the Simple scripts as well. Manual install time!

    extra db tables are painfully obvious ones, as shown here:

    Well, I went the route of manually installing, and I ended up with the same thing. I decided that there’s no way that this can be something wrong with WordPress, or else I wouldn’t be the only one with this problem, so I decided to check every little detail again.

    The good news is that I found what was wrong, and it wasn’t Simple Scripts. The bad news is that all this time, it was complete user error (i.e. me)… I somehow kept missing this line in wp-config.php:

    define( 'MULTISITE', true );

    Yep, one all-important line. I don’t know how I managed to miss it every time, and I’m a bit embarrassed at missing something like that, but I am very grateful for all the help, Ipstenu and Andrea_r. I’ve got it up and running now.


    If it helps, you’re not the first to miss that line. 🙂 Some people think it;s the same as wp_allow_multsite…. and it’s not. 😀

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘wp_1_ tables not created in new MultiSite install’ is closed to new replies.