Support » Plugin: WooCommerce Pay for Payment » WP4.9.1 Compatibility Issue

  • Resolved komagr

    (@komagr)


    I have detected a compatibility issue of this plugin with WordPress version 4.9.1.
    In essence, this plugin breaks Featured Image functionality in posts.

    In my particular situation I could not select a new featured image. The image select popped up correctly, but after I set an image and hit the button for completion, it does not appear at the ‘featured image’ part at all.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hi,

    I have the same problem. Deleting the featured image doesn’t work either.
    Please check.

    I have wordpress 4.9.1 and Woocommerce 3.2.6

    Thanks,
    Wim

    Plugin Author Karolina Vyskocilova

    (@vyskoczilova)

    Hi guys,

    I can’t reproduce the issue – having WP 4.9.1., Storefront 2.2.5, WooCommerce 3.2.6 and no other plugins installed. Saving, replacing and removing Featured Image (both in Post and Product) works fine. Are you sure, that is not another plugin/theme conflict?

    Have you tried to switch to Storefront theme and turn off ALL other plugins (only WooCommerce pay for payment and WooCommerce active?

    Could you turn on wp debug and send me the log here?

    Or could you give me the step-by-step manual how to reproduce the issue?

    Best regards and happy New Year!
    Karolina

    Hi,

    My first guess is it has something to do with polylang. I can’t turn off polylang though. I switched off all other plugins and if I have only polylang activated, I don’t have the issue. If I have ‘polylang’ and ‘pay for payment’ activated, I have the issue. Also if I have only ‘polylang’ and ‘Hyyan WooCommerce Polylang Integration’ activated, I have the issue.
    Checking the post action when pressing the ‘delete featured image link’, I have following parameters:
    pll_ajax_backend 1
    pll_post_id 45013
    post_id 0
    thumbnail_id -1
    action get-post-thumbnail-html

    –> As you can see, post_id = 0

    If I switch of pay for payment and I click the link again, I have the correct parameters:
    pll_ajax_backend 1
    pll_post_id 45013
    post_id 45013
    thumbnail_id -1
    _wpnonce a655cc00c8
    action get-post-thumbnail-html

    Hope this helps…

    Thanks,
    Wim

    Ok, for me it seems to be a combination of 3 plugins.
    If I only have woocommerce and then ‘WooCommerce Pay for Payment’, ‘WooCommerce PayPal Express Checkout Gateway’ & ‘WooCommerce Product Feed’ active, I have the issue. If I deactivate one of those 3, it works again…

    After all, the problem seemed to be in the woocommerce gateway paypal express checkout plugin.
    See github issue created:
    https://github.com/woocommerce/woocommerce-gateway-paypal-express-checkout/issues/362

    Plugin Author Karolina Vyskocilova

    (@vyskoczilova)

    Hi @wimvl, thanks for letting me know, interesting issue and glad that you have found what was causing this issue. I will keep it in my mind because you are not the first who have encountered it.

    Best regards and good luck, if I can help you, let me know!
    Karolina

    Hello people,

    Just letting you know what we are facing the exact same issue.

    Anyone found a walkthrough or we are waiting for the gateway-paypal-express-checkout to fix it?

    Regards

    Plugin Author Karolina Vyskocilova

    (@vyskoczilova)

    Hi, I think you can fix it yourself and(or) submit a push here, orherwise, no workaround is possible.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘WP4.9.1 Compatibility Issue’ is closed to new replies.