WordPress.org

Support

Support » Alpha/Beta » [Resolved] WP3.1-RC4 & Jquery Tabs : error

[Resolved] WP3.1-RC4 & Jquery Tabs : error

  • Hi; I use jquery tabs in my custom plugin.
    I had it working with wordpress 3; but seems the upgrade broke it.
    It tells me
    $(".oqp-tabs").tabs() is not a function.
    Like if the JS was not properly included.
    But I think it is :
    this code is located in my file oqp-tabs.js; which is included like this :

    <br />
    function oqp_single_oqp_post_scripts() {<br />
    	wp_enqueue_script('jquery-ui-tabs');<br />
    	wp_enqueue_script( 'oqp-post-admin-tabs', oqp_get_theme_url().'/_inc/js/oqp-tabs.js',array('jquery','jquery-ui-tabs'), OQP_VERSION ); //create and handle post tabs<br />
    }<br />
    add_action('wp_print_scripts','oqp_single_oqp_post_scripts');<br />

    So the dependencies (jquery, jquery-ui-tabs) are called.
    Any idea ?
    Thanks a lot

Viewing 6 replies - 1 through 6 (of 6 total)
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] WP3.1-RC4 & Jquery Tabs : error’ is closed to new replies.