WordPress.org

Forums

WP2.2 + email gone awry? (9 posts)

  1. PStamatiou
    Member
    Posted 8 years ago #

    Hey, my 2.2 installation doesn't email me since the upgrade. I have it set to email me with every new comment/moderation as well as nightly DB backups. I checked the admin settings for every page that asked for my email address - options, wp database backup, subscribe to comments, WP contact form and supplied it my email address.

    I haven't changed/added any plugins recently nor have I done anything on my server. I also double-checked my email to make sure emails didn't suddenly get routed to the spam box or anything like that.

    If it matters, the email address I supplied wordpress is through Google Apps for my domain and it's not the same domain that my blog is at.

    I read about WP2.2 doing mail things differently so I just wanted to stop by and ask.

    thanks,
    paul

  2. robcwright
    Member
    Posted 8 years ago #

    same problem here...

  3. astorg
    Member
    Posted 8 years ago #

    I had this problem too ever since I switched to Google Apps Hosted Gmail a few months ago (this was before 2.2). For a long time I wasn’t receiving any mail notifications and/or contact form mail.

    I finally solved it with a combination of several steps to completely revamp the way WordPress handles email.

    The first measure was installing the http://www.shiftthis.net/wordpress-swift-smtp-plugin/ plugin wish allows you to manage all your email using a secure connection via your Gmail SMTP server. This will work with Google Apps, but you need to tweak several of your PHP files and plugins that use email to make the switch functional (all explained on the plugin site). This got my contact form email back through.

    A second, apparently unrelated problem was that WordPress doesn’t seem to like it if you post articles using the same email address as the one used for admin and the one used for the plugin. I solved this one by using one address for my profile (the one my posts are signed under) and another for (1) blog admin and (2) the SMTP plugin email address (the one that any incoming email to me from the contact form or the WordPress admin gets sent to.

    I also got rid of the <wordpress@mydomain.com> default address that the standard install will set up and replaced it with my admin address.

    With these two additional steps, my comment and subscription notices started coming back through. It looks as if WordPress doesn’t like sending them to you if you are the author of the articles in your blog.

    The final touch was to disable email on my Media Temple (DV) 3.0 server. Although my DNS isn’t managed by Media Temple, I noticed that this final step (which I had overlooked when I switched my email to Google Apps) finally got me receiving notifications about 404 Errors (which had previously got swallowed up by the system despite all the above fixes).

  4. yanis
    Member
    Posted 8 years ago #

    Under WP 2.2 Contact form works fine for me (plugin) however wordpress generated email does not appear to be delivered to google apps hosted email*.

    That includes moderation and comment related email. I have changed to a different (non google apps) domain and whilst, again, the contact form works, internally generated email won't deliver either.

    * It should be noted that new user registration email has continued to work, but not to google apps, which does seem a tad odd when every other built-in mail function seems to have fallen silent.

  5. engtech
    Member
    Posted 8 years ago #

    This is really weird especially considering they just added support for this to wordpress.com

    http://wordpress.com/blog/2007/05/23/domain-mapping-and-email/

  6. elrope
    Member
    Posted 8 years ago #

    hello, my 2.2 installation doesn't email me since the upgrade. I have it set to email me with every new comment/moderation as well as nightly DB backups. I checked the admin settings for every page that asked for my email address - options, wp database backup, subscribe to comments, WP contact form and supplied it my email address.

    I haven't changed/added any plugins recently nor have I done anything on my server. I also double-checked my email to make sure emails didn't suddenly get routed to the spam box or anything like that.

    If it matters, the email address I supplied wordpress is through Google Apps for my domain and it's not the same domain that my blog is at.

    I read about WP2.2 doing mail things differently so I just wanted to stop by and ask.

    thanks,
    elrope

    Posted 4 days ago *

  7. astorg
    Member
    Posted 8 years ago #

    @===> engtech:

    What it amounts to is that wordpress.com has enabled the same functionality as can be achieved by taking all the steps I described above, viz.:

    - pointing MX records to Google Apps;

    - configuring SPF record to cover mail sent from both Google Apps and blog;

    - enabling an SMTP plugin that is Google-apps compatible.

    - disabling any mail functionality within one's own server to avoid any internally generated mail staying trapped there.

    Providing all these steps are taken, the WordPress/Google Apps combination will work and all mail, whether internal or external, will flow smoothly in both directions. I haven't tested ths under WP 2.2 yet, but I suspect that further changes in the way that mail and wp-mail operate will require further tweaking.

  8. astorg
    Member
    Posted 8 years ago #

    Because I was intrigued by the issues mentioned in this post, I took a while to test a fresh WordPress 2.2 installation's reliability for sending email. I set up a new site on a (gs) Media Temple server with a brand new 2.2 WP install and made the following modifications:

    (1) First I installed the ShiftThis.net | Swift SMTP plugin (http://www.shiftthis.net/wordpress-swift-smtp-plugin/) and set it up to send mail via the Media temple SMTP server that goes with the domain. Don't forget this is used, in principle, only TO SEND mail, so it is in no way inconvenient if I don't use my hosted Gmail. Using the latter, however will work but will result in any outgoing mail being logged in the "Sent" folder in the Hosted Gmail account, which may or may not be desired: choose accordingly. I configured my Gmail hosted Premier account to fetch any mail from this account using SMTP, just in case someone replies to an email sent using the actual address designated for accessing the SMTP server. I tested the plugin with Gmail Hosted also, and it worked too.

    (2) Second, I configured the SPF records for the Media Temple domain used as an SMTP server (just to make sure this is important, I tried sending an email from the domain using the SMTP server without having set a SPF record : it was sent safely but ended up in my spam folder and in Gmail or Hotmail would have been vanished without trace) I used the Media Temple default for this (v=spf1 a:yourdomain.com/20 ~all) but this can be refined if that mail server is used in other contexts.

    (3) I altered the pluggable.php file (found in the wp-includes folder) to replace "wordpress@mydomain.com" by "user@mydomain.com". This had best match the administration default set in the WordPress admin under >Options >General. This ensures that any admin-related mail sent via the SMTP server to myself arrives safely. It is important that this admin address is NOT the same as the address used to author posts, as WordPress does not seem to like that combination.

    (4) The last step, obviously, was installing a contact form (I used the WP-ContactForm: Akismet Edition [http://www.bloggingexpertise.com/plugins/wp-contactform-akismet/], basically because I liked the Askimet antispam feature and because it is fairly recent and works, but actually any contact form will do) and set it up to send any INCOMING messages to my Hosted Gmail Premier account. These arrived safely because Gmail established that the SPF record for the domain from which they had been sent specified that server as a legitimate author for that email.

    (6) With some plugins other than the Askimet Contact Form I mentioned (which will work with the ShiftThis plugin out of the box), it can be necessary to make the following change (detailed in the documentation for the ShiftThis.net | Swift SMTP plugin [http://docs.shiftthis.net/wordpress_swift_smtp_plugin]; if you’ve installed a plugin that sends email and does not seem to be working correctly with the Swift SMTP Plugin, do the following:

    i. Open the problem Plugin in a text editor.
    ii. Do a search for the function mail( and replace it with wp_mail(.
    iii. Upload the revised plugin and it should now use the SMTP setting for sending mail. (depending on which subscription plugin you're using, it might be necessary to edit it in this way; I needed to edit mine).

    Basically the key point is that if you set up your WordPress to send mail using a mail server that Gmail, with its strict anti-spam policies, regards as suspicious because the server it was sent through cannot be authenticated, the chances are the email will not arrive. This applies to both INCOMING mail (sent to you via the contact form) or OUTGOING mail (sent by the WordPress admin to you or to your readers or yourself regarding subscriptions, comments and registrations and the like) and anyone whose email provider has a strict spam policy will either not receive it at all or find it ends up in his spam folder.

  9. tartley
    Member
    Posted 7 years ago #

    Sorry for being dumb, but I still don't understand what the fix for this is. Do I have to replicate all the steps described above?

    I have wordpress 2.2, and when people left comments, wordpress used to send me an email. 9 months ago (June 2007) that stopped working, and I'm not able to get the emails to send again.

    I tried changing my email address as specified 'options/general options' to a completely different one, but that didn't seem to help.

    Can I easily tell whether emails are being sent by WP, but being dropped or filtered after that point? My WP is hosted at my webhost, not wordpress.com.

    Thanks for any advice.

Topic Closed

This topic has been closed to new replies.

About this Topic