Support » Themes and Templates » WP2 Themes – stylesheet missing error

  • Hi – I’ve just installed WP2 without any hiccups. I’ve been running 1.5 for about a year and wanted to start a new blog hence installation of WP2. I found some themes I’d like to try out, but most of them have not worked! It seems like there must be a problem elsewhere vs. all these different people having made the same error in creating their theme (especially since I know other people are running them).

    I have unzipped the files onto my hard drive and then moved the files via FTP to my host under the Themes directory. When I go into the Admin module, all but one of the 9 themes I’ve tried to install are listed as ‘broken’ with the same error – stylesheet missing. But it’s there!

    Themes I’ve tried installing are the following: ambiru, branches-theme, connections-reloaded, emire, jentri, lonelyroad, WP-DarkNight, and WP-DarkNight20. I’ve even tried adding themes from my 1.5 installation that I know work, but with the same problem. Help?!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Check the path in the theme’s header.php. It should look like this:

    <link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />

    Oh, and just for the record, the entire theme folder should be in wp-content/themes/

    Here’s something else simple to check

    Make sure your themes are not buried too deep in folders. I uploaded several themes to try out and got this same message. Turns out my folders were buried one folder to deep. Oops:)

    For example within the “connections” folder is another folder also named connections. It is that folder you should upload, not the top level folder.


    An ftp issue to check is to make sure you’re uploading the template files in ASCII mode. On some servers, text files ftp’ed as BINARY can run into issues.

    I had the same problem of missing stylesheets and (exactly as “bcp” advised above, it was due to a duplicated directory below the one where the stylesheets should havs been. Moved them (and deleted the lower folder) and problem was fixed.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘WP2 Themes – stylesheet missing error’ is closed to new replies.