Support » Themes and Templates » WP1.5’s default Kubrick stylesheet is refusing to be edited!

  • This is a protracted tale.

    I installed WP1.5 yesterday, and today while configuring and customizing, I accidentally made several mistakes in trying to get the template stylesheet to be writable. As I wasn’t sure about the chmods, I ended up winging it until 766 seemed to work. (Is that correct? Currently I have the files in the directory chmod’ed to 766 and the directory as 755. The codex help document lists both 766 and 666). I then made several mistakes while editing the stylesheet, and decided to delete the whole “default” directory and re-upload it from the fresh copy of WP1.5 I had on my computer.

    Now no matter what changes I make to the stylesheet, nothing shows up when I refresh my page. I tried everything from tentative font-color changes to wholescale structural upheavals, and the page stoically remains The other templates work fine – I removed the image CSS from the index with no problem, and I can mess around with all .php files. But nothing I do to the CSS file makes a difference. I’m familiar enough with CSS to know what I should be changing, but nothing I’ve done has worked. I’ve also downloaded other templates and installed them, and editing them is also fine. Basically, I seem to have screwed up the default stylesheet…somehow.

    If anyone has any suggestions on how to fix WP1.5’s Kubrick, I would be awfully grateful! There’s no Kubrick download for WP1.5 on Michael Heilemann’s website, and I didn’t think that re-uploading the directory would cause so much trouble (at least, I think that’s what did it).

    Sorry for making this long, and I do apologize in advance if I am being cretinous.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Okay, a couple of things.

    1) When you uploaded the new pages, and then made your changes, did you just hit refresh or use a forced refresh? In MSIE it is SHIFT+click REFRESH button. in Firefox it is Cntrl+Shift+R. You may then see your changes.

    2) When you delete files and upload them, you have to CHMOD them again (the ones you are using should be fine). Just because they are the same name doesn’t mean the CHMOD stuck. Same with the directories. Make sure they are set to what you want.

    With all of the “upheavails” you’ve been doing, you may have really messed something up. Try point one and see it that solves your problem, and then slow down and take a deep breath.

    If the only problem is the style sheet, and you’ve left the index.php and other templates alone, you can copy the style sheet (style.css) from the DEFAULT directory where you unzipped WordPress (or from the zip file you downloaded) and upload it to your site.

    Also, I just want to understand. Did you completely delete wordpress and then reinstall it, or just the theme? If the answer is WordPress, then did you run upgrade.php after uploading all the files? I’m swacking away at a bunch of possibilities here, but that’s how some of these things get solved.

    PS: I can see the changes I’ve made to default/style.css in both WP’s interface and my FTP client, but that same file viewed in my browser – – shows none of my changes.

    1) Believe me, I refreshed like, like cold beer on a hot day. I also switched templates several times before reactivating Kubrick to make sure I was forcing a proper refresh.

    2) I chmod every time I upload.

    3) I have also tried copying the original style.css file alone to my themes directory. The problem persists.

    In response to your question: No, not WordPress – I deleted the theme’s directory, i.e. themes/default and uploaded it again. More than once, I think, in my frenzied attempts to RESTORE ORDER.

    If you make the changes to the stylesheet, and then you upload the style sheet, and verify that it uploaded to the right time, place and so on, and you view the page (and it’s the right page..remember, you got a lot of things you’re working on) and it doesn’t change, and you’ve done something drastic like made the entire background RED, then….oh, wait, did you activate, deactivate, choose another theme and go back in the Presentation Panel?

    I’m grasping here. You’ve done all the right things. And from the sound of it, it sounds like you probably cleared your browser cache completely (In MSIE, Internet Options, delete temp files)….so this is what I suggest as a last resort, and then I gots to go to bed. I’ve been up since 4AM and it’s almost there again.

    Create a new theme subfolder and call it “hairlessme” or whatever. Upload a clean version of whatever you are working on only change the name in the top of the style sheet where it says “Theme Name” to “hairlessme” or something else.

    Upload all of this, do your CHMOD thing, and then go to Presentation in the Admin panel and select this new style.

    Now go see what happens. Maybe this might work.

    If not, anyone else got any ideas?

    It’s very strange – the page is updating but it takes an average of 4-5 hours for the changes I make in the stylesheet to show up on the actual site, no matter how much I refresh. I’ve tried everything – clearing the cache, closing the browser and reopening it, refreshing a billion times, opening the page in a different browser. I’m really very, very perplexed. If any genius out there has any solutions, please do let me know.

    I had a similar problem with updating the style sheet and found an inelegant solution. What happened was I could upload changes to php/html files into the theme folder and see the changes straight away, except for the style sheet, it would not update with a new upload. I logged into word press and checked it through the theme editor and the updates where there but when I went to site in my browser (clearing cache all the time) and viewed the style sheet, no updates. What I ended up doing was renaming the stylesheet and going into the header file and hard coding the style sheet link rather than use the php method. The path was exactly the same as what would get written out by php when you view the page source in the browser except with the new file name at the end. I then commented out the php style sheet link, uploaded it with the renamed style sheet and it worked a treat. Now everytime I upload a modified style sheet it appears instantly. I know this is not a great solution if you want to change themes regularly but it worked for me. I did notice that the image folder I was using in my css which was at the root level now seemed instead to go to the images folder in the theme folder, I can’t confirm this to be exactly the case but watch out for it. Hope this is of some help.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘WP1.5’s default Kubrick stylesheet is refusing to be edited!’ is closed to new replies.