WordPress.org

Support

Support » Plugins and Hacks » WP125 upgrade problem

WP125 upgrade problem

  • I upgraded my WP125 plugin to 1.3.0 and I get these errors when the ads are displayed. You can view the problem at http://startupstudent.com

    Not a huge deal … just wondering if anyone knows anything about this.

    Warning: Missing argument 1 for wp125_write_ads(), called in /home/coolbean/public_html/startup/wp-content/plugins/wp125/wp125.php on line 58 and defined in /home/coolbean/public_html/startup/wp-content/plugins/wp125/wp125.php on line 106
    
    Warning: Invalid argument supplied for foreach() in /home/coolbean/public_html/startup/wp-content/plugins/wp125/wp125.php on line 121
Viewing 15 replies - 1 through 15 (of 23 total)
  • same problem for me. example: http://www.highcountrymomsquad.com

    I bet it’s a typo mistake or something like that.

    I will look into it.

    I just tagged release 1.3.1. It should be available in 15 minutes or so.

    Not quite a typo, but close enough. Forgot to account for the possibility that the wp125_write_ads() functions probably wouldn’t have a new optional argument passed to it 99% of the time… 🙂

    Still an issue.

    Warning: Invalid argument supplied for foreach() in /home/coolbean/public_html/startup/wp-content/plugins/wp125/wp125.php on line 121

    Check out my site here

    Well, I’m flying blind here. I can’t reproduce the error myself, so I made some educated guesses and committed a 1.3.2 release that will *hopefully* fix it.

    This solved it for me. Thanks for the fast support.

    I up-grade and use 1.3.2 version of wp125, and the same problem Warning: Invalid argument supplied for foreach() in …/wp125/wp125.php on line 122.

    Any idea?

    I just upgraded to 1.3.2

    Everything is working great on my end!

    Thanks for the awesome support and fast support!

    I’m also using 1.3.2 and getting an error:

    …/wp125/wp125.php on line 122

    Using WordPress 2.7.1

    @edyrio and @ckohrman: Try deleting the plugin directory and re-uploading the files.

    I tried deleting and re-uploading the plugin, and I get this error:

    Warning: Invalid argument supplied for foreach() in /../wp-content/plugins/wp125/wp125.php on line 145

    PS- you and your plugin are awesome, thanks!

    Well, I’ll look into it… It’s strange though that some people get the error, and others don’t. Unfortunately, I’m the latter group.

    My guess is some PHP configurations respond differently to some part of the plugin source.

    What version of PHP are you running?

    I’m running PHP 5.2.8

    Hmm. My test box is running 5.2.5. We both have 5.2.x, so I don’t think the version itself is the problem…

    Wait…how many *active* ads do you have right now? Do you not have any? Because that might be the source of the problem. If you add one, does the error go away?

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘WP125 upgrade problem’ is closed to new replies.
Skip to toolbar