Support » Fixing WordPress » WP wont show my new posts (W3 total cache issue?)

  • Stijn

    (@claitonlord)


    Hello,

    WP wont show my last posts, even when i delete my browser cache. After i deleted my hosting cache i did see my new posts. I need to do this constantly, which is ofcourse super annoying. This also means that my visitors wont see my latest posts, untill i empty my hosting cache. Thats pretty crazy. I had W3 Total Cache inststalled, but deleted it some months ago. Are there still some pieces of codes from W3 in my WP installation? I think the problem did start after i deleted the plugin.

    What is going on here? I hope somebody can help me out.

    Thanks!

    • This topic was modified 1 week, 4 days ago by  Stijn.
Viewing 10 replies - 1 through 10 (of 10 total)
  • Moderator Steve Stern

    (@sterndata)


    W3 Total Cache installs files outside its plugin diretory. You also need to remove the db.php, advanced-cache.php and object-cache.php files manually from the wp-content/ directory.

    Stijn

    (@claitonlord)


    Hey Steve,

    Thanks. I dont see any of the folders you mentioned in my wp-content folder. Only one folder say cache and thats Autoptimize.

    Could they hide somewhere else? My URL is https://www.stijnspreekt.nl

    • This reply was modified 1 week, 3 days ago by  Stijn.
    Moderator Steve Stern

    (@sterndata)


    Then W3TC is not the issue.

    If you disable autoptimize as well, does the problem go away?

    Ask your host if they’re doing any caching, too.

    That your hoster’s pxc-cache acting up again Stijn (Autoptimize doesn’t do page caching) 🙂

    Stijn

    (@claitonlord)


    I deactivated Autoptimize and the problem is still there.

    I contacted my hosting and they are gonna try to solve it.

    Thanks.

    Stijn

    (@claitonlord)


    @ Frank and Steve, it was the expiring dates in my htaccess file that gave the cache problem. I dropped a piece of code there. My hosting provider told me this. I deleted everything there and the problem is solved. But now i have a ‘leverage browser caching’ problem. Look https://www.webpagetest.org/result/170110_2H_16HY/1/performance_optimization/#cache_static_content

    How can i solve this without ending up in the same situation again?

    • This reply was modified 1 week, 3 days ago by  Stijn.
    Moderator Steve Stern

    (@sterndata)


    Don’t bother chasing page speed scores. Make your site work well for real people.

    Stijn

    (@claitonlord)


    Ok thanks. So how do you experience my website speed Steve? 🙂

    Moderator Steve Stern

    (@sterndata)


    with local caching disabled, it’s a bit over 3 seconds to load everything, more than half of which is TTFB, indicating a slow server. You aslo have lots if images… try using Jetpack’s photon module which will allow things to be better parallelized by serving the images from a CDN.

    Stijn

    (@claitonlord)


    Aha i see. Thanks. So its worth to move to another hosting provider you think? And what do i need to look for?

    I will look for the Jetpack. I have heard of it. Is it easy to set up?

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.