Support » Everything else WordPress » WP won't save draft or publish for HOURS/DAYS

  • Hi,
    My website is:

    My problem is:
    I can’t Save Draft/Publish for HOURS.
    I have to keep retrying and retrying and finally hours later it will Save Draft/Publish.

    I’ve tried doing my stuff in Mozilla Firefox, I’ve tried it in IE, I’ve tried it in Google Chrome.

    I’ve tried turning off all the plugins.

    I’ve tried switching to the Twenty Ten theme to rule out theme-specific problems.

    Still no joy.

    EVENTUALLY the stuff will save draft/publish after many hours of trying and re-trying, but I need to get my posts done in a timely manner – and sometimes I’ve got deadlines, so I need this fixed.

    Appreciate any help with this, thanks!
    I’m not a coder, I use Headway’s visual editor so I don’t have to touch any code. But even when I had Twenty Ten or Atahualpa, there was the same problem.

    And I tried refreshing the page and trying again after I pasted the post contents again. No joy.

    And I made sure I had the latest version of everything. No joy.

    And I tried the MySQL database check and repair for each database – everything fine, then I tried save draft. No joy.

    I tried publish. No joy.

    I usually have to try and try and try again for HOURS, sometimes DAYS, then randomly, with nothing different it will suddenly save the draft or publish.

    ANOTHER weird thing is that down at the bottom of the draft I’m trying to save/publish, the little line that says when the draft was last saved, will show
    “Saving Draft…” and that line will just hang there like that.
    Refreshing the page will get rid of it, but then a couple of minutes later it’ll show that same msg and hang there. I’m not talking about the right column with the SAVE DRAFT or PUBLISH buttons, I mean right smack under the box containing the actual draft I’m trying to get to save or publish.

    I tried switching from VISUAL mode to HTML mode and then save draft/publish, but that doesn’t work either.

    Any help is GREATLY appreciated. I’ve been having this problem for MONTHS

Viewing 13 replies - 1 through 13 (of 13 total)
  • esmi


    Forum Moderator

    Have you considered using another hosting company?

    I’ve had this hosting company since 2008 and never had a problem until a few months ago – are you saying this is not a wordpress issue? I’ve seen other people on the forums over the years mentioning this same problem from time to time and the solutions suggested to them, which I’ve tried, haven’t worked.

    Based on everything you’ve tried, you’ve kind of run through all the possibilities in WP. After that, you hit Host problems.

    Are there any errors in your error log?

    Do you have any custom changes to revisions or otherwise in your wp-config file?

    I called the hosting company and they looked thru everything and said some of my databases were out of date with latin1 and needed to be converted to UTF-8 and to use the “UTF-8 Database Converter” plugin, so I’m trying that now…

    Ok, I’ve installed the plugin and converted the databases.

    And….no joy. Same problem, post won’t save draft.

    And the hosting company say they can’t help unless the error is reproducible, but it shows up at random times.

    I could be trying to save draft and it won’t work, I go to bed for a few hours, then try again and suddenly it will work, and all I’ve done was press the same save draft button I did a few hours previously!

    Any other ideas?

    What OS is this on? Windows XP, Vista 7 or a Mac?

    I use Windows Vista Home Premium

    And I’ve even tried bringing my laptop to the library and using their wifi, but still no joy.



    Forum Moderator

    This still sounds more like a hosting issue to me. The bit about changing the db tables is a red herring. If that was a real issue, the content would never get saved whilst here it does – eventually. Badly overloaded server?

    I just checked with them again, and while they said that they aren’t able to reproduce the error, they say that in March (when my problems began) they put filters on their servers to prevent hacking or spamming, and that somehow my posts are setting off those protections, even though they say they’ve looked over my stuff and can find nothing in my content that could possibly be triggering that, and can’t explain why sometimes the same content that won’t publish, will suddenly be able to publish on a random basis.

    I”m thinking of switching hosts if this doesn’t resolve soon. They grudgingly said they would have a supervisor look into it, even though their policy is to not do that if they can’t reproduce the error.

    Also recently I’ve gotten some comments that my pages are taking longer to load, so maybe it is an overloaded server they’re not admitting to. I’ll follow up on that, thanks.

    OOOHH! Ask them if they fiddled with mod_security

    Just got these two emails from my hosting company:

    Dear Lara,

    Thank you for contacting Technical Support. I have reviewed your account and I was able able replicate the issue we are seeing. It appears that whenever a post is saved, whether published or drafted, it is communicating with some outside server, and that communication appears to be formatted oddly which is causing the server’s Security System to flag and block the process.

    I am going to go ahead and escalate this issue to our Administrators so they can get an exception added to the Security System. Once this is done, this should correct the errors you were getting.

    We will reply again once the admins have added the exception to the system.

    Best Regards,

    Seth Jensen
    midPhase Technical Support Manager


    Dear Lara,

    We have added an exception for the security rule triggered previously. If you encounter any further errors please reply back with the steps to re-create the issue and we will take a look. Thank you.

    Best Regards,

    David Winans
    Systems Administrator
    So I just tried to save a draft and publish it and it worked, but that’s happened before. Buy anyway, hopefully this time their fix will work.

    Thank you everyone so much for all of your help. All of your suggestions were valuable in getting the hosting company to focus on a probable direction instead of claiming this or that problem with wordpress, like they were before I started trying all of your suggestions.

    I appreciate the kind support from everyone here on the forums!
    Lara N.

    It appears that whenever a post is saved, whether published or drafted, it is communicating with some outside server, and that communication appears to be formatted oddly which is causing the server’s Security System to flag and block the process.

    Imagine I’m raising my eyebrow like Spock.

    That’s interesting. It’s possible you have a plugin that’s calling out, but since you stripped everything down it’s highly unlikely. There’s no phone-out feature in WP when you safe a post as DRAFT. When you publish, yes, it’s sending out ping information if you left that turned on, but wow are they neglectful to not have tested that first 🙂 It’s not like WP is an uncommon app.



    Forum Moderator

    Well, at least we got them to own up to something. 🙂

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘WP won't save draft or publish for HOURS/DAYS’ is closed to new replies.