Support » Fixing WordPress » WP won't create the pages it claims were created

  • Hi, I have read some threads but none seem to be of any help.
    This is the problem: I have added some pages to my pages list in my Admin area of my blog, but whenever I click the view page button it takes me to a 404 Not Found page. I checked my FTP file manager and there’s no file that has the name of the page that was supposedly created anywhere in it. I also tried adding some more pages to see if it would work but still it doesn’t. This is the blog:
    None of the links to pages in the upper menu work.
    What can I do, is it the version, because I just recently upgraded to 3.1.1
    Please, help. :/

Viewing 9 replies - 1 through 9 (of 9 total)
  • WordPress doesn’t create a physical file for its pages and posts -they are entries in the database.

    Try changing the theme to Twenty-Ten and see if the problem continues. You also should reset your permalinks by going to Settings -> Permalinks. Select the Default option and save, verify that works. Then switch back to your desired preferred permalinks setup.

    If you set permalinks back to default and test, do your pages work?

    If so, is mod_rewrite enable on your server?

    Also, you will never find any file with the name of your page. No files are made for pages or posts. They are simply data contained within your mysql database

    Thanks for the response, guys.
    Well I went into my admin area but now I’m getting this message:

    You don’t have permission to access / on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

    Now I can’t even access my admin area, or the site for that matter. Did I get hacked? :/

    – switching to the Twenty Ten theme by renaming your current theme’s folder in wp-content/themes using FTP or whatever file management application your host provides.

    resetting the plugins folder by FTP or phpMyAdmin.

    Have you change any folder permissions?

    Looks like one or more required files have been deleted (like the index.php file). I recommend you do a new manual installation. You may want to back up wp-config.php and the wp-content folders before doing so.

    Doesn’t look like hacking. More like a screwup when working with FTP. The good news is that is unlikely your site is “lost” just missing the WordPress files.

    I backed up the files and removed WordPress from there… but now I get this message when trying to re-install it:

    The installation can not be completed:

    – You cannot install more than one script in the root directory of a domain.

    Click on the browser’s Back button to fix reported errors.

    So I went to the FTP manager and there’s nothing in the domain’s folder it’s completely empty, but I still get that message in Fantastico, even though in my WordPress dashboard it says I have no installations. I tried making a new installation in another folder and moving the files to the old folder but that doesn’t work either. 🙁

    Based on your descriptions, this is a hosting issue rather than a WordPress issue. It is possible that there are hidden files in your document root that is confusing the installer. Your hosting company is likely a better source for a solution.

    You might try copying the WordPress source files to your document_root rather than depending on the installer but you will then have to hand-edit the wp-config.php file with the correct database settings.

    Okay, I fixed it. I just had to delete the installed_in_root.php file from the .fantasticodata folder. The installation worked so I’ll try what you told me with the first question now. ^^

    thanks for all the help, guys. Now I finally got it to work right. Turns out all I had to do was edit the .htaccess file with the following code:

    Options +FollowSymLinks
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /2.0/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /2.0/index.php [L]

    # END WordPress

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘WP won't create the pages it claims were created’ is closed to new replies.