Support » Fixing WordPress » WP wants to create upload folder that already exists – now what?

  • Resolved Rosemary Senjem

    (@rosemarydesigns)


    Situation:

    • New install of 2.7 on new bluehost.com account with SimpleScripts
    • imported WP from version 2.7 on development server, where everything worked (including images for January 09, which generated this directory: /wp-content/uploads/2009/01)
    • permissions set to: 777
      • /wp-content/
      • /wp-content/uploads/
      • /wp-content/uploads/2009/
      • /wp-content/uploads/2009/01
    • Editing Draft blog entry
      • Try to upload image of a reasonable size (not too big)
      • get this same error message with browser uploader and flash uploader:
        Unable to create directory /wp-content/uploads/2009/01. Is its parent directory writable by the server?

    I found the thread in this forum about upload issues and took these actions:

    • deleted wp-admin folder and wp-includes folder from server in case SimpleScripts got it messed up
    • downloaded fresh version of WP 2.7 and uploaded fresh files of wp-admin and wp-includes

    I closed the browser, cleared the cache, logged out and logged back in.

    Problem still exists.

    Any Clues?

Viewing 15 replies - 1 through 15 (of 16 total)
  • Maybe try a complete manual install of 2.7. See the following video for step-by-step directions for doing this on Bluehost.

    How to Install WordPress through Cpanel

    Then, see the relevant parts of the following videos to move you database from your dev server to Bluehost…or just move the entire blog from your dev server to Bluehost as shown in the following videos.

    How to Move WordPress to a Different Server and Web Address

    that seems like a bit of overkill when EVERYTHING else is working great. Doesn’t someone know where the bug would be?

    Your site is broken…that process will fix it…overkill…if you say so 😉

    If you didn’t change url’s in your database, then I think you will soon find EVERYTHING else may not be working great, but good luck hunting down the bug.

    whooami

    (@whooami)

    Member

    its not a bug.

    so I understand what you are saying …

    you installed wordpress via simplescripts, than imported another blog that worked as you described?

    cheap fix:

    1. download the media in the directory to a backup
    2. delete it off the site
    3. let wordpress make the directory
    4. reupload your media

    Note that I still think this is a permissions issue on the new site — JUST as the error indicates. You’ll find out soon enough by going through the steps above. If not, than its a great fix.

    Thanks whooami for understanding where I’m coming from. I may need to reinstall, but that’s not the first thing I wanted to try. I seem to be one of those people who likes to know how things work.

    1. Log into WordPress.
    2. Go to your Settings->Miscellaneous config screen.
    3. Examine the directory parameter for uploads. It should be “wp-content/uploads”.
    4. Does it have a leading slash (“/”) in front of it? If it does, then that is your problem. Remove the leading slash.

    Bluehost’s servers don’t like 777 permissions.

    Is its parent directory writable by the server?

    This leads me to believe that it is having a hard time with the lenient permissions you have given it. Set your directories to permissions of 755 and your files to permissions of 644.

    OMG! OTTO42! THANK YOU THANK YOU! You saved me from a big waste of time that I cannot afford to lose right now! Easy Peasy Lemon Squeezy! YOU ROCK! YAY! HAPPY DANCE! WHEW!

    Yes, BernardBorealis, you are correct about Blue Host and 755 folders with 644 files works fine with WordPress. I called BH and got some great support from them, too. Thanks for adding that bit of info here for other folks. This is important stuff for people to know in case they find themselves in the same situation. Cheers!

    None of this worked for me. I am using SMEServer with a custom installation in an ibay of 2.7. Essentially, this is CentOS Linux with mySQL 4.x.

    I had to manually create /uploads/ and chown to www:<otherusergroup>.

    Once user www had permissions to write there, everything just worked.

    Not sure if this is a security risk, will monitor.

    Hope this helps.

    Thank you, Otto!!! I had the same problem and your tip worked!!! You rock!!!
    Lalala!!!
    Best

    osattack

    (@osattack)

    Otto, Thank You!!!!!!

    I have been fighting this problem since my server migration 2 weeks ago! Your fix worked perfect for me!

    allstonian

    (@allstonian)

    Otto Man! You rule. I was going to start from scratch…u just saved me a ton of time for such a silly thing.

    For the past 18 mos, I’ve been trying to convince my wife that our 2nd child, if a boy, should be named Otto. This might just be the thing to put me over the top.

    Cheers.

    Otto – you are the MAN!!!!!

    I also had the “upload directory doesn’t exist” problem for 5 months.
    Now that I followed Otto’s direction of finding the Miscellaneous config screen, it solved my problem.

    1. Log into WordPress.
    2. Go to your Settings->Miscellaneous config screen.
    3. Examine the directory parameter for uploads. It should be “wp-content/uploads”.

    When I changed server I made a different user name and once I changed it to the new user name, the “upload directory doesn’t exist” message went away.

    eg:

    server1: /home/aiyeold/public_html/blog/wp-content/uploads

    to

    server2: /home/aiyenew/public_html/blog/wp-content/uploads

    I second that,
    Otto – you are the MAN!!!!!

    Thank you,
    Aiye Knight

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘WP wants to create upload folder that already exists – now what?’ is closed to new replies.