WordPress.org

Forums

[resolved] wp uses different path to subcategory (2 posts)

  1. benraaa
    Member
    Posted 2 years ago #

    Dear friends

    I have got a problem with subcategories, where wordpress uses two different methods creating the path.

    I built a category hierarchy in this way:

    collection >> summer >> shirts

    I mapped this hierarchy in the custom menu, which leads to a correct path like

    http://mysite.com/page/collection/summer/shirts

    The permalink settings got the custom structure /%category%/%postname% and a category base "page" (without quotation marks).

    Furthermore there is a template for each category like category-shirts.php, which is correctly used when one navigates via the menu.

    These are the facts so far. But when I try to insert a direct link to the shirts category page via the link button in the editor and choose the category "shirts" from "or link to existing content" the link I get is

    http://mysite.com/collection/shirts

    This causes the correct output but doesn't use the category-shirts.php. Instead the index.php is used.

    Does anybody know how to solve this problem? Best solution would be with the correct path including all subcategories. But any solution with the use of the correct category template would be enough.

    Thanks in advance,
    benraaa

  2. benraaa
    Member
    Posted 2 years ago #

    Changed this topic to resolved because the question needs to be put differently...

Topic Closed

This topic has been closed to new replies.

About this Topic