Support » Plugin: WP-United : phpBB WordPress Integration » WP-United User Mapping Is Now Broken

  • Resolved Keith1028


    At some point there was a loss of data on my blog and now I get this error..
    admin.php?page=wpu-user-mapper returned: Error: Invalid XML:

    Here is the file that WP United asked me to include.

    [b]WP-United Version[/b] :
    [b]WordPress Version[/b] : 3.7.1
    [b]PHP Version[/b] :
    [b]WP-United enabled?[/b] : Yes
    [b]WordPress Home URL[/b] :
    [b]WordPress Base URL[/b] :
    [b]WordPress Plugin URL[/b] :
    [b]phpBB URL[/b] :
    [b]Plugin Path[/b] : /are/hidden/for/ised/all/ele/
    [b]WordPress Path[/b] : /are/hidden/for/
    [b]phpBB Path[/b] : /are/hidden/for/ments/
    [b]Active plugins[/b] : anonymize-links/anonymize-links.php, authorgrid/authorGrid.php, backwpup/backwpup.php, change-memory-limit/change-mem-limit.php, duplicate-post/duplicate-post.php, feed-key/feed-key.php, hello.php, limit-login-attempts/limit-login-attempts.php, mechanic-whos-online-visitor/wp-whosmechanic.php, members-only/members-only.php, members/members.php, no-revisions/norevisions.php, p3-profiler/p3-profiler.php, page-links-to/page-links-to.php, phpbb-topics-portal/phpbb_topics_portal.php, private-comment-notification-email/privatecomments.php, private-messages-for-wordpress/pm4wp.php, simple-local-avatars/simple-local-avatars.php, simple-login-log/simple-login-log.php, subscribe-to-comments/subscribe-to-comments.php, velvet-blues-update-urls/velvet-blues-update-urls.php, wassup/wassup.php, wordpress-importer/wordpress-importer.php, wordpress-mu-secure-invites/secure_invite.php, wp-grins/wp-grins.php, wp-image-size-limit/wp-image-size-limit.php, wp-last-login/wp-last-login.php, wp-polls/wp-polls.php, wp-united/wp-united.php
    [b]Current theme[/b] : DeafEars
    [b]Allocated memory[/b] : 4854.3469785575M
    [b]Memory limit[/b] : 256M
    [b]Locale[/b] : en_US
    [b]integrateLogin[/b] : 1
    [b]showHdrFtr[/b] : REV
    [b]wpSimpleHdr[/b] : 1
    [b]dtdSwitch[/b] : 0
    [b]phpbbCensor[/b] : 0
    [b]wpPageName[/b] : page.php
    [b]phpbbPadding[/b] : 6-12-6-12
    [b]xposting[/b] : 0
    [b]phpbbSmilies[/b] : 1
    [b]avatarsync[/b] : 1
    [b]integcreatewp[/b] : 0
    [b]integcreatephpbb[/b] : 1
    [b]xpostautolink[/b] : 0
    [b]xpostspam[/b] : all
    [b]xpostforce[/b] : -1
    [b]xposttype[/b] : excerpt
    [b]xpostprefix[/b] : [BLOG]
    [b]cssMagic[/b] : 1
    [b]templateVoodoo[/b] : 1
    [b]useForumPage[/b] : 1
    [b]wpuxpostcomments[/b] : 0

    All Help Is welcome

Viewing 9 replies - 1 through 9 (of 9 total)
  • I get the same errors and my interface is also broken.

    here’s how it looks

    I had my Tech guy fix this and he told me it was a cache issue…. I’m not sure what he changed.


    Thank you so much for sharing your your experience. It is very logical that it would be a caching issue. But i don’t use any cache plugins yet.

    I’m asking this to everyone, Is there a built in caching system for wordpress and the ACP? If so how can i flush it?

    Hi comziz,
    The same thing just happened to me on a test site on my localhost.
    Using Suffusion Theme.
    I deactivated all the plugins, but it didn’t help.
    I don’t have a caching plugin.
    I deactivated and deleted both wp-united plugins (the wordpress plugin and the phpbb mod)
    And I reinstalled them, but it still didn’t work.

    Then I looked inside the WP-United Folder. Sure enough there was one called Cache. Inside there was a readme.txt. It told me to delete the Cache folder since WP-United would just build me a new one. I did. It still didn’t work. The readme.txt also said to look at my options.php file (Inside the WP-United Folder). There were lots of settings that can be changed safely.

    Here is part of one:

    * The template cache is only used when you use the 'phpBB inside WordPress' template integraqtion in 'simple' mode. 
    * It SIGNIFICANTLY improves page generation time, as WordPress no longer needs to be invoked on phpBB pages just to get a header and footer.
    * However, if you have dynamic elements in your header or footer, then you will want to keep this option off.
    * To turn it on, change FALSE to TRUE.

    This fixed it…so far… I hope it stays fixed.
    I had installed this configuration before and didn’t need to make this change before. I don’t understand why it broke but if anyone can explain it, I’d love to know.

    Oh, I forgot to say, I changed it from TRUE to FALSE.

    Thank you so much for your contribution skylar180,

    But unfortunately changing
    define(‘WPU_CACHE_ENABLED’, TRUE);
    to FALSE

    didn’t solve my user mapping issue.

    When I click on “User Mapping” I still get,
    “admin.php?page=wpu-user-mapper returned: Error: Invalid XML: Showing 1 to 10 of 12 WordPress users.”

    and when I click on “New Permissions”,the blue dots and the red squares are still not where they’re suppose to be, and I can’t drag and drop them. =(

    I got the exact same message except for the number of users. I only had 2.

    Here’s another thing I did, BEFORE I had changed the options.php file:
    I went into the phpBB ACP and then clicked on the Permissions tab.
    Setting Permission there is the same as using the red/blue dot thing — only difference is, it works. My red/blue map doesn’t work either, it just spazzes out.

    For each type of user (Admin, registered, new registered, etc…) you click on the different tabs and choose what you want to allow them to do.
    The last tab is the WP-United Tab and that’s where you will change the setting for user mapping.

    I’m new to this so I didn’t make too many changes. Just a couple on the WP-United tab.

    Try that and see if it works for you.
    Also, when done, maybe empty the cache folder so that new stuff gets built inside it.

    Any idea why though I am logged into WP, I am not logged into PHPBB? I could have sworn this worked not long ago, but have a feeling I might have done something.


    This tip was what helped me.
    Essa dica foi o que me ajudou.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘WP-United User Mapping Is Now Broken’ is closed to new replies.