WordPress.org

Forums

Import CSV with Ultimate CSV Importer
[resolved] WP Ultimate CSV Importer : Featured Image Issue (25 posts)

  1. delaney101
    Member
    Posted 1 year ago #

    Hi all,

    I'm having a problem importing images using WP Ultimate CSV Importer. No matter what I try, the text will be imported from the CSV but never the images. No error is shown, the images just aren't there I have included my .csv file (perhaps I am going wrong somewhere with this).

    Any help at all would be much appreciated. Thanks in advance

    https://docs.google.com/file/d/0Bx-E4Y4EDrprVVJaRE1NTlFTUTA/edit?usp=sharing

    (you may not be able to view this in Google doc as it is .csv but you can download it).

    http://wordpress.org/plugins/wp-ultimate-csv-importer/

  2. smackcoders
    Member
    Plugin Author

    Posted 1 year ago #

    You must use a supporting format. The 2 images in provided csv are in gif format and another one is http://nearlycracked.com/wp/wp-admin/post.php?post=28&action=edit. These types have issues in importing.

  3. delaney101
    Member
    Posted 1 year ago #

    Hi, thanks for the speedy reply.

    I have changed the URL to include a .JPG rather then a .gif but this does not seem to have resolved the problem. There is still no feature image set when the upload has completed. I have edited my CSV accordingly and attached the new version.

    Could you check if you are having the same issue?

    https://docs.google.com/file/d/0Bx-E4Y4EDrprbUthNU5Qbm5URmM/edit?usp=sharing

    Thanks in advance

  4. smackcoders
    Member
    Plugin Author

    Posted 1 year ago #

    Kindly test in our live demo instance here. You have to use JPG image itself instead of renaming the gif version.

  5. delaney101
    Member
    Posted 1 year ago #

    Hi,

    I have used a jpg image itself. It is a totally different image to the previous gif used.

    I tried the live demo. The file imported (as with my Theme) but nothing appears in the posts section (unlike with my theme) therefore I cannot check if the feature image is there or not.

  6. delaney101
    Member
    Posted 1 year ago #

    Hi there, any luck with this? I have read that I should add add_theme_support( 'post-thumbnails' ); to my functions.php file.

    However I don't think this will solve my problem as I already have the "Featured Image" metabox visible in my options. I can upload images manually using this, however the plugin will still not import images from the csv file using the .JPG Url's in order to do a bulk import.

    Any ideas?

    Thanks in advance

  7. smackcoders
    Member
    Plugin Author

    Posted 1 year ago #

    Is that worked in our live demo? I have no idea what is going wrong. Any i will take a note of this. If it is found as bug, i can try to find a solution or fix. As far as now we cant reproduce the same issue in our test environment.

  8. delaney101
    Member
    Posted 1 year ago #

    The live demo allowed me to upload the .csv file and said the files imported but when I looked at the "Posts" section none of the posts from the .csv file were there at all. No text or pictures.

    When I import to my theme there is text but no feature image. Can I ask were you able to upload the .csv file and create posts with both text AND featured images?

  9. smackcoders
    Member
    Plugin Author

    Posted 1 year ago #

    Do you have the sample files to import. If not get it from here for testing. If you can import the sample file then you should make need to check the csv file.

  10. delaney101
    Member
    Posted 1 year ago #

    Thanks for the reply. I imported your sample post file to my theme and it did not set the feature image. The same problem as I have found with my csv file

  11. smackcoders
    Member
    Plugin Author

    Posted 1 year ago #

    Is that not importing in live demo also?

  12. delaney101
    Member
    Posted 1 year ago #

    It says it has imported successfully but when you go to the post section they are not there.

  13. smackcoders
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry delaney101, i can even import now in live demo. You have to find what is wrong with you.

    Try like this

    Go to post import
    Choose the sample file i gave without any change to import
    Choose sticky as post status to identify the imported post easily
    Now map everything including the featured image
    Hit import and go to post list view
    You can see posts imported with status as Sticky
    Click edit to see imported fields including the image as well

    I can see no issues, you just missed out to see the imported posts. You can use the sample file to built your csv for a successful import.

    Thanks and all the best.

  14. delaney101
    Member
    Posted 1 year ago #

    Hi smackcoders. You are correct when I upload my own .csv file to your demo it works as expected and displays the image. This is not the case when I upload to my theme.

    I will contact the theme supplier. Thanks

  15. fresh99
    Member
    Posted 1 year ago #

    Hi delaney101,
    I am having the same issue. I also tried my .csv on the demo site and there it works fine. When I tried it on my theme on my server it didn't work. Have you tried to install another theme on your server that does support feature images? With the new theme upload the .csv and then switch back to your own theme. Locally my theme works perfect. Have you checked your theme locally (using Xamp f.e.)?

  16. delaney101
    Member
    Posted 1 year ago #

    Hi fresh99, I tried it on the Twenty Eleven theme and still the images would not import. I have also tried adding add_theme_support( 'post-thumbnails' ); to the functions.php folder, this did not work either.

    I'm at a loss now!!!

    Sorry I'm not familiar with Xamp. If you are able to get it to work please post your solution. I will do the same :)

  17. fresh99
    Member
    Posted 1 year ago #

    Hi delaney101,
    To make sure the problem was not in my theme I installed a WordPress installation locally using Xamp (See here) When I tested the .csv file it worked fine with my theme. The external images were imported into the media manager and the featured images showed in the front and backend of WordPress. It's nice to have Xamp for yourself but if want...I can do a local test import with your theme. What is the name of the theme you are using? If your theme also works locally you have to check your hosting.

  18. delaney101
    Member
    Posted 1 year ago #

    Hi freah88, thanks so much that's very kind of you but I'm actually using a paid theme. I will download Xamp and try it myself later. Thanks for the tip.

    I still have not had any luck importing the images have you? Did you try the importer that comes with WordPress instead? The .xml layout is a little more complicated though.

  19. delaney101
    Member
    Posted 1 year ago #

    *fresh99 :)

  20. fresh99
    Member
    Posted 1 year ago #

    I am still have the problem. I am waiting for a response of my hosting. In the meantime I figured that if WP Ultimate CSV works using Xamp, I could do an export with WordPress to xml and then import the xml file the WordPress installation on my server. This resulted in the same respons. Everything was imported except for the featured image.

  21. delaney101
    Member
    Posted 1 year ago #

    I contacted my hosting. They said it would be a permissions issue and I should change my folder permissions (where the content is being uploaded).

    "To prevent this from happening in future, all you need to do is ensure the permissions set on the upload folder are 775 (as opposed to 771 which it most likely is at the moment). Once you have done this any files uploaded in future will upload with the correct file permissions (either 664 or 644) and thus will be seen when uploaded."

    This did not work either!. I worked to allow the the WP importer import images, but not for this plugin. The problem with this plugin is not that the images are not being displayed correctly but that they are not being uploaded / imported at all!

  22. fresh99
    Member
    Posted 1 year ago #

    I tried these permission settings without any luck either.

  23. fresh99
    Member
    Posted 1 year ago #

    Hi Delaney, I finally got this to work. I contacted my hosting and the problem was caused due to the allow_url_fopen option being disabled in my php.ini file. Once I enabled it. It works perfect.

  24. delaney101
    Member
    Posted 1 year ago #

    Hey fresh99, that's great. I contacted my hosting company but they said fro security reasons they will not allow me to enable the allow_url_fopen option :(

    Back to the drawing board for me :(

  25. delaney101
    Member
    Posted 1 year ago #

    Ok got this resolved by uploading the images o my media library then taking that url and using it in my CSV.

    Thanks for the help

  26. delaney101
    Member
    Posted 1 year ago #

    Hey guys, I manged to get the featured images importing but I have found that the feature images are being pixilated after import.

    Firstly I upload the image to the Media Library. The image is clear and has a size of approx 300-400kb. After I import it using the media librarys url ...uploads/picture.jpg for example. The image then appears blury in the featured image area of the post. When I check the media library the image I uploaded has been reduced in size approx 50kb and in addition a new image of approx 50kb is also there. This is the image WP is telling me is attached to the post.

    Has anyone else encountered it?

    Thanks in advance

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Import CSV with Ultimate CSV Importer
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic