Support » Plugin: WP UI - Tabs, Accordions, Sliders » WP UI Conflict with Autoptimize

Viewing 13 replies - 1 through 13 (of 13 total)
  • Hi Drizzle;
    I’m the Autoptimize developer. I would start with trying with “force JS in head” (possibly combined with “look only in head”).

    Alternatively you could start by trying to exclude jquery.js (or jquery-min.js or jquery.min.js) if those are not loaded from CDN and exclude “wp-content/plugins/wp-ui/js/” as well, but I guess the good people here can help with identifying more specifically what needs to get loaded early.

    Hope this helps,
    frank

    Hello frank,

    Thanks for responding so quickly.

    I use the WP UI plugin to create numerous tabbed history content pages. Here’s one of the broken tabbed pages:

    http://www.wyofootball.com/history/spartan-wall/spartans-2012/

    Your plugin is great and doesn’t seem to conflict with my other plugins (except for a small problem with TablePress – the “sorting” feature becomes disabled, but I can live with that).

    Right now I have Autoptimize enabled with the Optimize JavaScript Code, Force JavaScript in <head> and Look for scripts only in <head> checked. Nothing else is checked, and I currently do not have a script related to WP UI excluded.

    Thanks again, Scott

    The sorting feature in TablePress is now working…. The tabs in WP UI remain broken.

    hmmm, you could try exclusing jquery and “/wp-content/plugins/wp-ui/js/”?

    Excluded jquery and a js file associated with wp-ui and that seems to resolve the problem. Thanks.

    Great, I’ll close the topic in the Autoptimize support-forum as well, linking to this here topic.

    Might be interesting for others here to know what WP-UI javascript you excluded from being aggregated?

    I have a similar problem with PolyLang. I would try to exclude jQuery and js file associated with WP-UI. Can you please explain how this is done?

    Thank you.

    The answer is a couple of responses higher John;

    excluding jquery and “/wp-content/plugins/wp-ui/js/

    You might also want to read the troubleshooting topic in the AO FAQ.

    Thank you Frank.

    However, I resolved this issue by uninstalling the current version 0.8.8 and installing the previous version, 0.8.7 located on this page:
    http://wordpress.org/plugins/wp-ui/developers/

    digitalmoxie

    (@digitalmoxie)

    I am having the same issue and nothing seems to be working. I have excluded every javascript file associated with this plugin and it still stops showing my tabs every time I check Optimize JavaScript Code?. Can someone put exactly what you put into the exclude field that worked. My list right now is below, its still wrecking my wp-ui.

    admin.js, async.js, begin.js, editor_dialog.js, end.js, jquery-1.10.2.js, jquery-ui-1.8.4.js, jquery-ui-1.10.3.js, jquery-ui.js, jquery-ui.min.js, jquery.colorbox-min.js, jquery.js, jqui-admin.js, widgets.js, wp-ui-old.js, wp-ui.dev.js, wp-ui.js, wpui_tour.js, wpui-styles-demo.js, acc.js, init.js, spoiler.js, tabs.js

    Hi digitalmoxie;
    I would try to;
    * enable “force JS in head” and/ or “look only in head”
    * exclude jquery.js (or jquery.min.js or jquery-min.js) and /wp-content/plugins/wp-ui/js/
    * enable “try/ catch wrapping” to avoid interference from other js-problems

    hope this helps,
    frank

    Can you please write down instructions how to do this:

    * enable “force JS in head” and/ or “look only in head”
    * exclude jquery.js (or jquery.min.js or jquery-min.js) and /wp-content/plugins/wp-ui/js/
    * enable “try/ catch wrapping” to avoid interference from other js-problems

    Thx, BR

    just check out the autoptimize admin screen BR, if you need more info the autoptimize FAQ will probably be your best friend 😉

    frank

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘WP UI Conflict with Autoptimize’ is closed to new replies.