Support » Plugin: wp-Typography » wp-typography stops shortcode from beeing computed

  • Resolved augschburger

    (@augschburger)



    Hi – I use the Smooth-Slider plugin with shortcodes in sidebar widgets for a while. Today I changed something in this site (added a new sidebar) and now I have to disable wp-Typography to make Smooth-Slider working.
    If it’s enabled, the shortcode is displayed, i.e. [smoothcategory catg_slug=”partner”]

    I fiddled with wp-Typography settings (disabled Intelligente Zeichenersetzung and Typographische Anführungszeichen, added textwidget and widget_text to ignored CSS-classes), but with no success.
    For me it seems, that wp-Typography changes something in the shortcode before it is parsed by WP.

    This behaviour is reproduceable, if I enable wp_Typography and flush caches, the shortcode is displayed on the website. Once I disable wp-Typography and flush caches, the sliders are working again. I already disabled all other plugins and deleted and reinstalled Smooth-Slider with no success.

    Thanks for any hints!

    The page I need help with: [log in to see the link]

Viewing 15 replies - 16 through 30 (of 32 total)
  • Yes, I had disabled it, it’s enabled now.
    Plus: I removed the <h2> tags, now it’s ok on the homepage (not wrapped in a text widget), but still no hyphenation in the sidebar (text widget). Hmm…
    I’ve deleted the filter from functions.php, restartet Apache, checked on three different browsers, disabled caching, no idea…

    Plugin Author pepe

    (@pputzer)

    Is it possible that the theme caches the sidebar? (Try changing the text in the slider to see if it is really current.)

    The filter function used for the post content and the text widget is identical.

    (Try changing the text in the slider to see if it is really current.)`

    I did, it was immediately visible. I think I give up on that – I guess nobody will realize it… The main thing is to have the slider back. 🙂

    Plugin Author pepe

    (@pputzer)

    @augschburger: On my test system with just Smooth Slider and wp-Typography, the slider text is hyphenated even in the sidebar. If it’s not on your site, the reason lies either in your configuration or some other plugin.

    Now that I think about it, you mentioned that you added various classes to ignore in your intiial experiments? Maybe one of those settings interferes?

    augschburger

    (@augschburger)

    you mentioned that you added various classes to ignore in your intiial experiments?

    *scratching my head*
    Not sure what you mean. It wasn’t me! 😀

    The slider which displays text is created with a text-widget like
    <div class="achtgruendeslider">[smoothcategory catg_slug='gruende']</div>

    The text is not hyphenated, until I set

    .achtgruendeslider {
      hyphens: auto;
    }

    That’s OK for me – but: The first slide is really ugly hypenated, the rest is OK…
    I think I should become a lumberjack.

    Plugin Author pepe

    (@pputzer)

    You wrote “added textwidget and widget_text to ignored CSS-classes” in your initial support request. Those two should not have a direct effect (because they are not actually passed to the filter), but if you added additional classes that are generated by Smooth Slider to the “CSS-Classes to ignore” field, then that could be the reason).

    hyphens: auto; asks the browser to do hyphenation, which is totally different from what wp-Typography does. Are any other typographic enhancements applied to your sidebar sliders? If not, a misplaced class, ID or tag name in the “ignore” lists is the most likely culprit.

    • This reply was modified 1 year ago by  pepe.
    augschburger

    (@augschburger)

    Are any other typographic enhancements applied to your sidebar sliders?

    Not that I know. The ignore lists only have the default values because of “Alles zurücksetzen” – I didn’t change the ignore lists. But I have hit the default-button again right now, just to be sure. I only needed to disable the “Et-Zeichen”, because it es rendered wrong otherwise – different story…
    hyphens: auto; is removed now from the CSS…

    Plugin Author pepe

    (@pputzer)

    @augschburger Could you please something like “wrap numbers” and add some numbers to one of the sliders? Then you should see (by looking at the source, it should contain <span class="number">...) if any enhancements are actually applied. If not, I’d like you to try and disable everything except wp-Typography and Smooth Slider. Those two work fine when I run them locally.

    augschburger

    (@augschburger)

    <span style="font-family:Tahoma,Geneva,sans-serif;font-size:14px;font-weight:normal;font-style:normal;color:#06648d;"> 
    Aus früheren Tätigkeiten bei EDV-Beratungen und IT-Systemhäusern bringen unsere Mitarbeiter langjährige (über 100 Jahre in Summe) Erfahrungen in der Beratung und Betreuung mittelständischer Unternehmen mit. 
    </span>

    The same text on the frontpage is wraped…

    I’ll make a copy of the site before disabling the plugins, just a minute…

    augschburger

    (@augschburger)

    I’d like you to try and disable everything except wp-Typography and Smooth Slider.

    Been there, done that. Plus AnimateIt to get the shortcodes working in 4.8.3.
    Result: wrapped and hyphenated:
    http://xxx.sico-systems.de/sico-systems/

    I’ll activate the plugins one at a time now and check the sidebar.

    Plugin Author pepe

    (@pputzer)

    🙂

    augschburger

    (@augschburger)

    The culprit is “WooSidebars” – which is kind of a problem, because I need different sidebars per topic…

    What way shall we go? Fixing wp-Typography or searching for another sidebar-tool?
    Anyway: Thanks again for your support!

    Plugin Author pepe

    (@pputzer)

    Since it is a free plugin, I’ll have a look at the problem next weekend. At a first glance, I didn’t notice anything obvious in the code.

    augschburger

    (@augschburger)

    No problem!
    I just realized that WooSidebars hasn’t been updated for a long time, so it’s maybe a good idea to choose another plugin like “Content Aware Sidebars”.

    Plugin Author pepe

    (@pputzer)

    Have you had success with that other plugin?

Viewing 15 replies - 16 through 30 (of 32 total)
  • The topic ‘wp-typography stops shortcode from beeing computed’ is closed to new replies.