Support » Plugins » WP to Twitter not working with Postie

  • Because I’m all about automation, I use the Postie plugin to create blog posts from my phone via email and the WP to Twitter plugin to announce to the world that I’ve done so. Problem is, when I post via email, no Tweet is generated. If I post via the WordPress admin page, I do get the Tweet (although I don’t think WP->Twitter is working with QuickPress). Has anybody else seen this? Do you have a solution or idea?
    I’m pretty knowledgeable of PHP, and am comfortable fixing bugs within the plugins if that’s needed, but I’m willing to forgo foraging through the plugin source if anyone can offer advice.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Have you enabled remote publishing? There’s an option in the settings to enable remote publishing which should enable posting via email. If that is enabled, then it’s a separate issue – and I’ll work on it!

    And no, QuickPress isn’t working. There isn’t a lot of information available on the actions triggered in QuickPress (although I believe it’s new_to_publish.)

    Thanks for responding. Yes, “Send Twitter Updates on remote publication (Post by Email or XMLRPC Client)” under WP->Twitter settings is checked and I tried turning on “Atom Publishing Protocol” and “XML-RPC” under the general writing section, although I don’t think that should matter for e-mail posting. — Still no tweet! I haven’t tried remote posting without using the Postie plugin. I’m using a number of other plugins, mostly limited in scope with the exception of WP Super Cache.

    Is there any other information I could give you that would help? QuickPress isn’t really a concern for me, although your comments about that are interesting if I get to making some more plugins of my own.

    Thanks, charminggeek – I’ll download Postie and see if I can get that working. WP Super Cache shouldn’t have any impact, so it’s probably a problem with the post by email interactions.

    In fact, the problem is a bit deeper – email posting doesn’t seem to be working at all. I’ll have to dig in and find the problem!

    Thanks for bringing this to my attention –

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘WP to Twitter not working with Postie’ is closed to new replies.