WP to Twitter
[resolved] WP to Twitter (6 posts)

  1. mcasdorph
    Posted 4 years ago #

    I'm getting this from the WP to Twitter admin dashboard:

    Connected, but getting a notice that your Authentication credentials are missing or incorrect? Check whether your Access token has read and write permission. If not, you'll need to create a new token.

    Twitter is set to read and write, so I don't know what to do, I have setup and used WP to Twitter before, I can't figure this out!


  2. Joe Dolson
    Plugin Author

    Posted 4 years ago #

    Are you getting a notice that your Authentication credentials are missing or incorrect? Are you able to post to Twitter?

  3. pyxis630
    Posted 3 years ago #

    Just installed the plugin and get a similar message.

    The credentials are correct, Twitter is set to Read and Write, I also tried with Read, Write and Access direct messages. Posting to Twitter does not work. WP to Twitter version is 2.4.4

    One guy over at Twitter suggests that the plugin wasn't authorized by Twitter (https://dev.twitter.com/discussions/3929). Could that be an option?


  4. Joe Dolson
    Plugin Author

    Posted 3 years ago #

    That message is not an error message - it's just a hint of something to look into if, after connecting to Twitter, you are receiving a message that your authentication credentials are missing or incorrect when you attempt to tweet.

    Are you getting that as an error? If not, what error are you getting?


  5. pyxis630
    Posted 3 years ago #

    I ended up starting over. Resetting the plugin, creating a new app over at twitter and made sure that I created the access token after I changed the setting to read/write. I cannot remember if I did this before, I might have created the access tokens in read only mode first and changed it afterwards and re-created them.

    Although I still get the credentials missing notification, it also says it is connected and started to post to twitter. I received no errors today after posting to twitter.


  6. airbornex
    Posted 3 years ago #

    I too have an issue with the same troubleshoot message.

    I have followed the steps closely and done all necessary steps (i.e. Read & write permissions, fill in all 4 key information etc), got the API key for my account from bit.ly, but it isn't posting to my twitter account. I have recreated the app and the keys 5 times and it is still showing the same message, with no tweets posted.

    I can tell that this is a great plugin but it's a pity that I can't seem to use it. :(

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP to Twitter
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic