Support » Plugin: WP to diaspora » WP to diaspora incompatible with Gutenberg?

  • Resolved SGallay

    (@sgallay)


    Hello,

    WP to diaspora has been of great help to me for a long time, but it suddenly stopped working with Gutenberg. It used to work with earlier versions, but it seems that, after adding the Gutenberg extension (version 6.8), it’s doing nothing.

    In edit mode, WP to diaspora shows in the Document sidebar, but all check boxes and radio buttons are inactive and cannot be clicked.

    Any idea on how to solve it (besides deactivating Gutenberg)?

    I’m on the latest WP version (5.24).

    • This topic was modified 2 years, 9 months ago by SGallay.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter SGallay

    (@sgallay)

    It seems to have been fixed with the new versions of Gutenberg, I’m marking this closed.

    Plugin Author noplanman

    (@noplanman)

    @sgallay I’ve just released version 3.0.0.

    Please give it a go and give me any feedback, thanks!

    Thread Starter SGallay

    (@sgallay)

    @noplanman Hi! Thanks for the heads up!

    I did and ended up with a nasty error:

    Fatal error: Uncaught Error: Call to undefined method WP2D_Options::attempt_password_upgrade() in /home/clients/5addc5133f10047669fa2f96c2a3b9cb/web/wp-content/plugins/wp-to-diaspora/lib/class-wp2d.php:210 Stack trace: #0 /home/clients/5addc5133f10047669fa2f96c2a3b9cb/web/wp-includes/class-wp-hook.php(287): WP2D->upgrade('') #1 /home/clients/5addc5133f10047669fa2f96c2a3b9cb/web/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(NULL, Array) #2 /home/clients/5addc5133f10047669fa2f96c2a3b9cb/web/wp-includes/plugin.php(478): WP_Hook->do_action(Array) #3 /home/clients/5addc5133f10047669fa2f96c2a3b9cb/web/wp-admin/admin.php(170): do_action('admin_init') #4 /home/clients/5addc5133f10047669fa2f96c2a3b9cb/web/wp-admin/index.php(10): require_once('/home/clients/5...') #5 {main} thrown in /home/clients/5addc5133f10047669fa2f96c2a3b9cb/web/wp-content/plugins/wp-to-diaspora/lib/class-wp2d.php on line 210

    Plugin Author noplanman

    (@noplanman)

    @sgallay so sorry about that!

    Clearly the deploy script was missing something, should be ok now with 3.0.1.

    πŸ™

    Thread Starter SGallay

    (@sgallay)

    No harm done! Thank the WP devs for recovery mode. πŸ™‚

    I’ve updated the extension and re-ran today’s blog post to check, it worked fine. Thank you!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WP to diaspora incompatible with Gutenberg?’ is closed to new replies.