WordPress.org

Support

Support » How-To and Troubleshooting » WP Time Stamp is not working correctly

WP Time Stamp is not working correctly

  • The wordpress time stamp / scheduling feature is not working correctly for me.

    In my draft post the status is set to draft, visibility is set to public, and then I go down to the option where I can set a time to post it and when I choose a date and press OK it says:

    Publish on: Jan 20th 15:16 (as an example)

    But then when that time comes the post doesn’t go live and it just says “missed schedule”

    Any ideas on what is going on here? I’ve never had an issue with this feature in every other version of WP.

Viewing 15 replies - 1 through 15 (of 19 total)
  • See if this helps:
    http://wordpress.org/support/topic/227101?replies=8#post-960717

    Essentially the suggestion is to visit Administration > Settings > Writing and delete all but http://rpc.pingomatic.com/ from the Update Services list.

    Please let us know if that does (or does not) work for you. Thank you.

    Hey MichaelH thanks for the response, unfortunately I only have the default one that comes when you install WP.

    Any other ideas?

    Interesting… so if I just replace that file with the one I have it will work?

    You would need to edit that one line in cron.php.

    If that solves (or doesn’t) solve your problem please let us know or comment on the trac ticket (user your forum login there)

    There is no “wp_remote_post” even in the wp-cron.php file that comes with the WordPress 2.7 package though…

    I’m looking at the file that sites in the root directory called wp-cron.php should I be looking somewhere else?

    (Sorry for delayed response I wasn’t able to even have time to try this out until tonight).

    Disregard that last message I found the right cron file and have made the change. I’ve scheduled a post to go live tomorrow so I’ll let you know if it works.

    This did not work. I changed from 0.01 to 10*60 but when I logged into my WordPress control panel it still just said “Missed schedule”

    This is incredibly odd to me that in every version of WordPress I’ve used before it’s worked just fine and suddently it does not here. Granted this is a new installation on a new theme, but I don’t know why this isn’t working.

    Might look at this though I’m not exactly clear what jadebydesign did… http://wordpress.org/support/topic/221086/page/2?replies=45#post-968631

    Dang… that didn’t work either. How could something work fine through WP and then on a new install of 2.7 not work? This is key functionality heh heh…

    Any more ideas?

    Sorry. You might keep and eye on these threads:
    http://wordpress.org/tags/27scheduledposts

    Hey Michael,

    Is this the give up point then? I appreciate all your help, but my guess is that I’ve now run out of options.

    Can you at least confirm if this will be fixed in 2.71?

    Hey thehalogod,

    What I did was download WordPress version 2.6.5 and ftp’d two files from it up to my WordPress 2.7 installation. The two files were:

    wp-cron.php and cron.php

    wp-cron.php resides in the root WordPress installation and cron.php resides in the wp-includes folder and basically uploading both of these files overwrote the WP 2.7 versions of these files and everything worked.

    In wp-cron.php there is a line about “local time” in the coding and I suspect that if your web server is not exactly correct in the local time from what WordPress perceives it to be, then the timeout of zero to do the cron job will effectively cancel the trigger of the scheduled post.

    These two files in WordPress 2.6.5 do not have the “local time” variable in the code as well they have a trigger time of +30 and this fix really does work for about 97% of the folks who have tried it so far.

    Since it’s not working for you, double-check that you uploaded both of these files to the right folders, double-check that you can overwrite these files and your server does not have them write-protected somewhow, make sure you’re not running on a Windows 2003 server or you will have to do an iisreset in order for the cron jobs to trigger in wp-cron.php and cron.php

    If all this still doesn’t get you up and running then have a look at some other variables like are you able to run a backup of your website? Any other cron jobs? Do they work or not? Perhaps it’s an issue at your server level and not in WordPress?

    One thing I did before I tried this fix that I came up with is I set up a sub-domain on my hosting account and loaded in WordPress version 2.6 and tested a scheduled post, it worked like a charm. Then I loaded in WordPress 2.7 and scheduled a post, it failed saying “Missed Schedule” so I satisified myself that the problem was definitely not with my server but with WordPress 2.7 – Overwriting those two files did the trick for me and quite a few others now…

    Sorry it isn’t working for you…I hope they resolve this in the next version of WordPress…

    Hey Jade,

    I tried your steps actually (commented on your blog too) thanks for the help though but unfortunately this didn’t work for me.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘WP Time Stamp is not working correctly’ is closed to new replies.
Skip to toolbar