Support » Networking WordPress » WP switching to main blog on publish/update: Sitewidetags plugin issue?

  • I have a multisite installation on one domain with 24 network blogs in sub-directories. I’m using the Sitewidetags plugin to pull post excerpts and thumbnails from the network sites onto the main blog. This seems to be working OK.

    But I am experiencing three problems which may be related:

    Firstly, when publishing/updating a post I frequently (but not always) get an error message telling me I have attempted to update a post which does not exist; I have to use the back button to return to the previous page. However, the post has been published normally when I check in a separate browser.

    Secondly, when I update or make a new post, instead of returning the updated page in the admin I am often (but not all the time) switched to a completely different (apparently random) post in the main blog (the admin switches to the main blog also). The original post is published, however, and the thumbnail and post also pulled to the main blog OK.

    I have tried switching off the Sitewidetags plugin, and a post can be updated normally (obviously not being pulled to the main blog), although as the fault is intermittent this is not yet conclusive.

    Thirdly, but more rarely, when opening to the main blog home page, I experience a delay and then it flicks to a network blog home page url, which usually does not load completely. On refresh the correct home page is loaded.

    The network runs off a litespeed hybrid server with 2GB RAM so there’s no problem with resources. I have installed WP Total Cache network wide, but have not set any JS or CSS to be minified as I encountered some configuration issues. I use disk enhanced for the page cache, disk for minified, opcode for object cache and database cache, and browser cache is also activated. Memcached is available on the server but I have not implemented it in WP TC.
    The theme used is Studiopress Genesis Lifestyle on all sites.

    I am using Firefox and Chrome on Windows 7 and Vista. The server is in Chicago, we are running off cable in Sydney Australia.

    Anyone experienced anything similar?

Viewing 15 replies - 1 through 15 (of 21 total)
  • I did, once, and after deleting the plugin and scrubbing it out of he DB, and reinstalling it, it went away and i never saw it again. I have no idea what I did wrong, but I can only assume I screwed something up.

    Sounds hopeful! When you say “scrubbing it out of the DB” can you be more specific, i.e. what else do I need to do other than delete the plugin before re-installing?

    After disabling and removing the plugin, I searched the databases for all references to it and deleted that as well. I did not make a list of it all.

    Thanks a lot, Ipestenu, I’ll give it a go.

    Well, I deleted the plugin, couldn’t find any reference to sitewidetags in the DB (or anything that looked relevant) and now get on updating get an error with the phrase: ” You tried to edit a file which does not exist. Perhaps it was deleted?”. However, in distinction to others who have had the same error in the past, my post actually updates.

    Obviously as I get an error message I don’t know whether the weird redirection problem has been solved as yet. More posts are due out later so I can check then (the site is live).

    Sorry, I should have mentioned I reinstalled the latest dev version of the SiteWideTags plugin.

    Unfortunately,the re-installation has not got rid of the weird redirects, as an update of a network blog post (which went through) resulted in a redirect to the edit screen of a “featured page” from the main blog home page (this has also happened on a previous occasion when a post was being updated, ending up at the edit screen of a different page featured on the home page).

    I should note that the featured pages where I ended up are actual pages created on the main blog, and not pulled in from elsewhere. Hmmm.

    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    could be url collision?

    Are you editing the original posts and NOT the ones on the tags blog? (cuz that’d do it.)

    Yes, Andrea we are certainly editing the original posts, as they are the canonically important ones. But as a coding ignoramus I’m unclear as to how this would influence the set-up with the tags blog. We’re being redirected to a blog page that has nothing to do with the copy of the original post on the tags blog. How does this url collision come about, and does it simply result in a random redirection?

    Presumably the “You have tried to edit a file that doesn’t exist..” message is also involved, or would that be a separate issue?

    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    What’s in the error logs?

    Nothing relevant at the moment, Andrea, I’ll come back to you when the next updatee is made in the morning…my time, sorry, it’s a bit late here in Oz!

    After quite a bit of checking, I found nothing relevant to my problem in the error logs (see below).

    The problem of the error on updating is persisting (“You tried to edit a file which does not exist,” etc.

    Re switching: if I use the preview prior to updating a published post (in the network blog where it was first published), I am frequently getting the preview with the correct title and head, but the wrong post content. This content is from the post that is linked to as “prev” in the head. However, it is usually from a completely different blog.

    A similar behaviour has occurred today when publishing a post for the first time, I have been switched to a post listed as “prev” in the wordpress links in the header.

    In addition, on several occasions now I have been switched to the home page of a subsidiary blog when calling up the main domain home page in the browser (my browser home page is set to it). A refresh brings up the correct home page, but it’s a little worrying.

    Error logs after updating (error message in browser but blog updated):

    2011-02-09 01:24:59.418 [INFO] [] File not found [/xxxxx/xxxxxx/public_html/404.shtml]
    2011-02-09 01:24:59.418 [INFO] [] File not found [/xxxxx/xxxxxx/public_html/wp-content/uploads/2010/03/France_Helen_1331.jpg]
    2011-02-09 01:24:56.904 [INFO] [] File not found [/xxxxx/xxxxxx/public_html/404.shtml]
    2011-02-09 01:24:53.056 [INFO] [] File not found [/xxxxx/xxxxxx/public_html/404.shtml]
    2011-02-09 01:24:53.056 [INFO] [] File not found [/xxxxx/xxxxxx/public_html/wp-content/uploads/2009/12/ajp_4340.jpg]
    2011-02-09 01:24:48.608 [INFO] [] File not found [/xxxxx/xxxxxx/public_html/404.shtml]
    2011-02-09 01:24:48.608 [INFO] [] File not found [/xxxxx/xxxxxx/public_html/navbar_inf.php]
    2011-02-09 01:24:17.690 [INFO] [] File not found [/xxxxx/xxxxxx/public_html/404.shtml]
    2011-02-09 01:23:46.138 [INFO] [] File not found [/xxxxx/xxxxxx/public_html/404.shtml]
    2011-02-09 01:22:59.679 [INFO] [] File not found [/xxxxx/xxxxxx/public_html/404.shtml]
    2011-02-09 01:22:25.462 [INFO] [] File not found [/xxxxx/xxxxxx/public_html/404.shtml]
    2011-02-09 01:22:25.462 [INFO] [] File not found [/xxxxx/xxxxxx/public_html/wp-content/uploads/2010/05/Eglise-Saint-Ephrem.jpg]
    2011-02-09 01:21:48.276 [INFO] [] File not found [/xxxxx/xxxxxx/public_html/404.shtml]
    2011-02-09 01:21:31.008 [INFO] [] File not found [/xxxxx/xxxxxx/public_html/404.shtml]
    2011-02-09 01:21:31.008 [INFO] [] File not found [/xxxxx/xxxxxx/public_html/httptest_target.php]
    2011-02-09 01:21:30.929 [INFO] [] File not found [/xxxxx/xxxxxx/public_html/404.shtml]

    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    Hmm, well that is interesting… they are going to server 404 pages and not WP ones.

    I think that’s because I chose to let the server handle 404’s for static objects in WP3 total cache browser cache settings.

    More importantly, looking at my Google Analytics which gives more detail on 404 requests, I find that the main cause of error is a request from e.g. the Spain blog for a post on Dali which ended up as a request for the post but in the Bulgaria blog, where of course it did not exist. The problem appears to have its root in this arbitrary blog substitution, with the latter part of the request being correct.

    As an experiment, I have deactivated the SiteWidePlugin network wide and will see if that makes any difference. Otherwise it must be something to do with WP# total cache or APC.

    We have just updated two posts and published a new one on different blogs. All went through normally without any error messages or blog switches. While clearly this is not conclusive, it does appear prima facie evidence that the SiteWideTags plugin had something to do with my problems.

    I see Ron has announced a new version of the plugin. I was using the development version downloaded on 6 Feb, has there been any changes since then?

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘WP switching to main blog on publish/update: Sitewidetags plugin issue?’ is closed to new replies.