Support » Plugins and Hacks » WP Super Cache » [Resolved] [Plugin: WP Super Cache] WP Super Cache won't write to supercache or debug file

[Resolved] [Plugin: WP Super Cache] WP Super Cache won't write to supercache or debug file

  • I recently moved my wife’s site to a new server. The move went smoothly, but I have not been able to get the supercache to function on the new home (which I administer myself — it’s a Rackspace server, as was her previous server).

    However, WP Super Cache doesn’t work now. I have tried deactivating and reinstalling the plugin twice now, to no avail. The plugin doesn’t create any files in the cache or supercache directories (it won’t even create the supercache directory). Neither PHP nor mod_rewrite caching seems to be effective.

    The plugin won’t even create a debug file — when I turn debugging on, it says that it is logging to a text file, but it doesn’t actually create the file.

    Running the Cache Tester returns a result of “The pages do not match! Timestamps differ or were not found!” in both PHP and mod_rewrite modes. When I run the cache test, the plugin is able to create the “1.html” and “2.html” files in the cache directory. So it seems to be able to write to the directory just fine.

    When I experimented and tried to do a preload, an empty “preload_mutex.tmp” was created in the cache directory, and that was it.

    I have been through the FAQ and the troubleshooting steps any number of times now. Everything seems to be in order. The htaccess rules are in place when I’m trying to run mod_rewrite caching, and they’re out of there when I’m trying to run PHP caching. All the proper Apache mods are in place. The wp-cache-config and advanced-cache files appear to be correct as far as I can tell, although I have tried recreating them (as per the troubleshooting instructions) a number of times.

    The plugin is not throwing any errors on the settings pages.

    I feel like I’ve tried everything. Can you offer some guidance?


Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Donncha O Caoimh


    That’s really bizarre. Can you delete wp-content/advanced-cache.php and wp-content/wp-cache-config.php and reinstall again?

    Ha, I know, it’s weird, right? What I ended up doing, on your advice, was deactivating and deleting everything, including the wp-super-cache folder in wp-content/plugins. Then I re-downloaded and reinstalled the plugin from scratch. Now everything’s working like a charm! The poor thing just got confused, I guess.

    I really appreciate your quick reply. It was a relief just to have it confirmed that this behavior was so strange. Thank you for this great software; I just made a PayPal donation as a more tangible thanks.

    Plugin Author Donncha O Caoimh


    Wow, glad it started working in the end! And thank you for the donation, much appreciated!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] [Plugin: WP Super Cache] WP Super Cache won't write to supercache or debug file’ is closed to new replies.