Support » Plugin: WP Super Cache » WP Super Cache Settings

  • A couple of questions (any help is appreciated):

    1. I’m seeing this error under “Directly Cached Files”. Warning! /xxx/xxx/xxx/xxx/xxxxx/
    domains/ is writable. Please make it readonly after your page is generated as this is a security risk.

    Since I have the CHMOD set to 750, I believe the permissions are correct. Any thoughts? (Note: x’s were just added to mask the path.)

    2. If I want to disable the mobile support, which part of the mod rewrite rules should be removed?

    3. I’ve also got the following in my .htaccess and I’m wondering if any of these would conflict with the plugin:

    #AddHandler application/x-httpd-php5 .php

    AddHandler php5-script .php

    <ifModule mod_headers.c>
    Header unset ETag
    Header unset Last-Modified
    FileETag none

    <FilesMatch “\.(ico|pdf|flv|jpg|jpeg|png|gif|js|css|swf)$”>
    Header set Expires “Mon, 27 Dec 2010 20:00:00 GMT”
    Header set Cache-Control “public, no-transform”

    php_value output_handler ob_gzhandler

    <IfModule mod_deflate.c>
    AddOutputFilterByType DEFLATE application/x-javascript text/css text/html text/xml

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Donncha O Caoimh


    1. 755 is usually ok. The directory is probably owned by the webserver. Ignore the warning or talk to your host about it.

    2. The rewrite_cond lines with the user agents.

    3. The php_value directive probably will, and mod_deflate too when you enable compression in the plugin.


    On No. 2, when I remove those lines, I see this. Just wondering if it’s normal. I have mobile support disabled.

    A difference between the rules in your .htaccess file and the plugin rewrite rules has been found. This could be simple whitespace differences but you should compare the rules in the file with those below as soon as possible. Click the ’Update Mod_Rewrite Rules’ button to update the rules.

    Plugin Author Donncha O Caoimh


    Just ignore it. 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘WP Super Cache Settings’ is closed to new replies.