[resolved] WP-Super Cache: pages do not match. timestamps differ (3 posts)

  1. TheVirtualPreacher
    Posted 4 years ago #

    I am using WP-Super Cache for caching which worked fine until yesterday. This is how the problem started.

    1. I deactivated all plugins to troubleshoot a different issue.

    2. WP-Super Cache generated 3 error messages upon deactivation as I deactivated it without switching off the cache first.

    Error message 1: Warning: implode() [function implode]:Invalid arguments passed in /home/virtudwt/public_html/wp-content/plugins/wp-super-cache/wp-cache.php on line 2498

    Error message 2: Warning: implode() [function implode]:Invalid arguments passed in /home/virtudwt/public_html/wp-content/plugins/wp-super-cache/wp-cache.php on line 2499

    Error message 3: Warning: Cannot modify header information - headers are already sent by (output started at /home/virtudwt/public_html/wp-content/plugins/wp-super-cache/wp-cache.php on line 2498) in /home/virtudwt/public_html/wp-content/plgins/ylsy_permalink_redirect.php on line 423

    I ignored these messages and reactivated WP-Super Cache later. Now the plugin isn't caching anything at all. Testing the cache throws the following error.

    Fetching http://www.virtualpreacher.org/ to prime cache: OK

    Fetching first copy of http://www.virtualpreacher.org/: OK (1.html)

    Fetching second copy of http://www.virtualpreacher.org/: OK (2.html)

    The pages do not match! Timestamps differ or were not found!

    I quickly concluded this is something specific to WP-Super Cache and tried Green Cache, Hyper Cache, Quick Cache and W3 Total Cache. None of them works.

  2. Donncha O Caoimh
    Posted 4 years ago #

    Uninstall the plugin completely and install it again. Maybe some configuration variable was reset incorrectly.
    Also use the debug system, that will help, and examine the 1.html and 2.html when using the tester.

  3. TheVirtualPreacher
    Posted 4 years ago #


    Re-installing WordPress by going to Dashboard > Updates > Re-install now fixed the problem.

Topic Closed

This topic has been closed to new replies.

About this Topic