Support » Plugin: WP Super Cache » WP Super Cache not working – timestamps don't match?

  • Hi,

    I’ve recently installed WP Super Cache on a site it’s not working. I get the following error message:

    Cache Tester

    Test your cached website by clicking the test button below.

    Fetching http://www.opticallock.com/ to prime cache: OK

    Fetching first copy of http://www.opticallock.com/: OK (1.html)

    Fetching second copy of http://www.opticallock.com/: OK (2.html)

    The pages do not match! Timestamps differ or were not found!

    Things you can do:

    Load your homepage in a logged out browser, check the timestamp at the end of the html source. Load the page again and compare the timestamp. Caching is working if the timestamps match.
    Enable logging on the Debug page here. That should help you track down the problem.
    You should check Page 1 and Page 2 above for errors. Your local server configuration may not allow your website to access itself.

    The website is http://www.optincallock.com. I previously tried W3 Total Cache which didn’t work properly, but deleted it and put in WP Super Cache

    I just turned on the debug function in Super Cache. Can someone assist?

    Thanks,

    Phil

    https://wordpress.org/plugins/wp-super-cache/

Viewing 15 replies - 1 through 15 (of 17 total)
  • I was able to fix this. Could someone please answer my other question about pre-load and minify in WP Super Cache?

    Hi,

    I thought this was resolved, now it’s happening again. I had deleted/reinstalled and the timestamps matched, but now overnight the error is showing again. I have turned debug back on. Can anyone help?

    Sorry. No idea on what’s happening. Probably, you may try disabling CloudFlare by putting it in development mode and see if the error still occurs. At times, CloudFlare creates similar issues.

    Had the same problem. Turning on CloudFlare development mode did indeed resolve the issue.

    However, does this mean WP Super Cache is incompatible with CloudFlare (when not in development mode)?

    @edwardspek

    As already mentioned…

    At times, CloudFlare creates similar issues.

    It doesn’t mean WP Super Cache is incompatible with CloudFlare. In order to understand what’s happening, you must understand how both work and what they actually do.

    Short answer: You may ignore the timestamp error. Rest assured, things would work as configured.

    If you are too concerned about timestamp error, then, setup “s-maxage” header to a very high value via .htaccess (or whatever the configuration your server supports) and configure CloudFlare to cache dynamic content too. By default, CloudFlare is set to cache static content only.

    I am using any CDN, But i am facing this Problem, What can i Do? Can any one help me plz?

    Problem:The pages do not match! Timestamps differ or were not found!

    First and foremost, is your website on a CDN? If yes, CDN like Cloudflare certain configuration in it conflict with WP Super Cache. This article might help you with that https://www.msgdigital.com/wp-super-cache-tester-pages-not-match-fix/

    I had that same issue on my website and I follow that method and it worked.

    Hope this help all of you guys.

    Cheers.

    I had this issue too and I solved disabling Cloudflare Railgun.

    Hello, I do not have railgun and I tried everything but still have the issue.

    The pages do not match! Timestamps differ or were not found!

    But, when debugging and checking log file, it seems that the correct cached file is loaded.

    Can you find a possible reason for this ?

    Thanks.

    Whoa, Cloudflare indeed create the “problem”

    At first I checked the timestamp via terminal and it was matched but reported as not matched… then I enabled Cloudflare development mode and viola now they are matched!

    I have this problem and don’t even use cloudflare!

    Hello all,

    How can this be fixed please?

    Regards,
    Peter

    Cache Tester

    Test your cached website by clicking the test button below.

    Fetching http://www.gravevisit.com/ to prime cache: OK

    Fetching first copy of http://www.gravevisit.com/: FAILED

    Fetching second copy of http://www.gravevisit.com/: FAILED

    One or more page requests failed:

    The pages do not match! Timestamps differ or were not found!

    Can you check if your pages are actually cached ? The test fails but pages are actually cached on my websites.

    I also have the timestamp error message. Doesn’t seem anyone really knows the best and sure way to fix this. I don’t use cloud flare either. If not fixed shortly though time to try a different Caching solution. I don’t like errors

    Plugin Author Donncha Ó Caoimh

    (@donncha)

    @bformhals19 – use the debug log and see what the plugin is doing. It can be complicated but it’s worth trying. Do not paste the contents of the debug log here though as it contains sensitive information about your site.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘WP Super Cache not working – timestamps don't match?’ is closed to new replies.