Support » Plugin: WP Super Cache » WP Super Cache no longer caching (solution known)


    After updating to version 1.6.8 or higher, the option “Don’t cache for logged in users or those that comment” is changed to a split set of options “Known users” and “Users that have a cookie”.

    Now the DEFAULT is “Known Users” with internal value 2, but for the websites that already had this plugin, the value for “known” was 1 and that is now “Users that have a cookie”.

    The problem with this is that it checks for ANY cookie. Not a specific set of cookies, no option to ignore certain cookies, no. if ($_COOKIE) { dontCache(); }
    The issue with this is that EVERY WEBSITE HAS AT LEAST 1 COOKIE. There is the “I don’t want to be tracked” cookie. The “WordPress tests if cookies are available” cookie. need I go on?

    My point is; any website that upgrades from 1.6.7 to higher will no longer cache pages, requiring a configuration change.

    So be warned; if you upgraded to a version above 1.6.7 and have not yet checked, or perhaps you came here first to see “why does my website no longer cache pages”, this is probably the reason.

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘WP Super Cache no longer caching (solution known)’ is closed to new replies.