WordPress.org

Forums

WP-Super Cache: No Cache (15 posts)

  1. adamelijah
    Member
    Posted 7 years ago #

    I have WP-SUper Cache on for a couple weeks and it's showing 0 pages cached and I have all the settings per what's posted in the options menu.

  2. jackiedobson
    Member
    Posted 7 years ago #

    Anything in the webservers error logs?

    Can you please provide some details as to what you've done and are seeing?

  3. adamelijah
    Member
    Posted 7 years ago #

    I installed Super Cache. There's nothing in the error logs about Super Cache, but the site does keep crashing. I installed SUper Cache nnd followed the instructions in the manual to intall it. Result=No cache.

  4. tiosolid
    Member
    Posted 7 years ago #

    The same with me. I have two blogs and in one the plugin is caching just fine, but in the another one its always says "0 super-cache and wp-cache pages". No errors at the webserver logs.

  5. s2j
    Member
    Posted 7 years ago #

    I'm seeing the same thing here. It's been a couple of weeks, and I'm not getting any help here. Good luck!

  6. erick_paper
    Member
    Posted 7 years ago #

    Why are you using WP-SuperCache instead of WP-Cache? I mean, what is the benefit? WP-Cache is more mature, innit?

  7. Donncha O Caoimh
    Member
    Posted 7 years ago #

    erick - WP Super Cache is based on WP-Cache so most of the code is as mature as that was. Go read the plugin page to find out why the new plugin is better. It's self evident!

    adamelijah, s2j, tiosolid - is there anything in wp-content/cache/ ?
    Is there a wp-content/cache/supercache/ folder?
    In wp-content/wp-cache-config.php, what is the value of $super_cache_enabled ? Is it true or false?

    Try changing $sem_id to 5418 or 5420, that might improve things.

  8. tiosolid
    Member
    Posted 7 years ago #

    FYI, i just did this, and hell yeah, it worked:
    - Deleted the plugin folder;
    - Deleted the advanced-cache.php files from plugins folder;
    - Edited the wp-config (i guess this one made it work) and deleted the 'wp-cache true' thing. Its almost in the end of the file now between the { };
    - Installed the plugin again;
    - worked o.0

  9. I'm still having problems getting anything to cache what so ever. I've followed the steps provided by tiosolid and others on reinstalling and that doesn't solve the problem either. I've even tried changing the SEM_ID from 5419 to 5418 and that didn't even work. I guess some of us are stuck with regular old WP-Cache huh?

  10. s2j
    Member
    Posted 7 years ago #

    donncha:

    $super_cache_enabled = true; //Added by WP-Cache Manager
    $sem_id = 5418;

    No luck. 5420 doesn't help either.

    Here's what my cache directories look like:

    $ ls -al cache cache/meta/ cache/supercache/
    cache:
    total 20
    drwxrwxrwx 4 apache apache 4096 Jan 21 15:04 .
    drwxr-xr-x 5 apache apache 4096 Jan 16 21:56 ..
    -rw-rw-rw- 1 apache apache   81 Jan 16 21:55 .htaccess
    drwxrwxrwx 2 apache apache 4096 Jan 21 15:03 meta
    drwxrwxrwx 2 apache apache 4096 Jan 21 15:04 supercache
    
    cache/meta/:
    total 8
    drwxrwxrwx 2 apache apache 4096 Jan 21 15:03 .
    drwxrwxrwx 4 apache apache 4096 Jan 21 15:04 ..
    
    cache/supercache/:
    total 8
    drwxrwxrwx 2 apache apache 4096 Jan 21 15:04 .
    drwxrwxrwx 4 apache apache 4096 Jan 21 15:04 ..

    Note that the supercache directory was not created for me. I just made it to see if it would help. It didn't.

  11. s2j
    Member
    Posted 7 years ago #

    Ok, here's the deal with my problem:

    The placement of the WP_CACHE define matters! This is not mentioned in the readme, but it does matter. Donncha: please update the readme! I originally had it at the bottom of my wp-config. Now, it's immediately after my database login info. This is all it took to solve my problem.

  12. Huh. I would have thought that obvious, but perhaps not.

    Yes, the WP_CACHE must be defined before the require_once(ABSPATH.'wp-settings.php'); line. Anywhere above that in wp-config will do.

  13. Donncha O Caoimh
    Member
    Posted 7 years ago #

    s2j - just checked in a change in trunk making that clearer. Thank you. I would have thought it was obvious too but:
    1. It's easy to drop the define() at the end of the file in a moment of "oh why isn't it working?" angst.
    2. Not all WP users are any good at PHP!

  14. s2j
    Member
    Posted 7 years ago #

    The plugin complains if that line is not in the file. If you place that line at the bottom of the file, the plugin stops complaining. I think that's where the confusion arose.

  15. pavs
    Member
    Posted 7 years ago #

    Just logged into say what tiosolid said works.
    I spent many many days trying to get it work. It finally works. Thanks!!

Topic Closed

This topic has been closed to new replies.

About this Topic