WordPress.org

Support

Support » Plugins and Hacks » [Resolved] wp-super-cache – missing mod_headers error

[Resolved] wp-super-cache – missing mod_headers error

  • Everything seems to be working fine but I’m getting the following msg on the settings page:

    Missing Apache Modules

    The following Apache modules are missing. The plugin will work without them but your visitors may see corrupted pages or out of date content.

    mod_headers – Required to set caching information on supercache pages. IE7 users will see old pages without this module.

    What modules are these and where do I get them? How and where do I install them?

Viewing 6 replies - 1 through 6 (of 6 total)
  • You should talk to your admin or check /etc/apache2/ if you have root access to your server. On Debian boxes you should look in /etc/apache2/mods-available/ and mods-enabled/

    Not sure about other systems but searching using Google should answer your question.

    Thanks. I don’t have root access to the server so I’ve forwarded your message to my hosting provider.

    UPDATE: Unfortunately, since I host my blog on a shared-server. I can’t make the changes. I got the following message from the tech support guys:

    I am sorry but we cannot change the server configurations as we maintain a standard prep across all our shared hosting servers. Custom modules can be implemented only on dedicated server solutions

    BTW I use Total Choice Hosting for my hosting needs.

    I am using QNAP-639 and also have this message in the WP Super Cache setting page. I can not find the mod_headers either. How can I resolve this problem ?

    Change to half-on mode and don’t worry about it. mod_headers is only required for serving static cache files. You won’t notice any difference unless your blog makes it to the front page of digg for some ridiculously popular post (which is unlikely, unfortunately!)

    Thanks for that info Donncha, very helpful but I have root access to my Debian server and still can’t find either of those modules or how to turn them on!?

    Glad you got it working – http://twitter.com/reverbstudios/statuses/1529319972 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] wp-super-cache – missing mod_headers error’ is closed to new replies.