WordPress.org

Support

Support » Plugins and Hacks » WP Super Cache Messes Up Feedburner

WP Super Cache Messes Up Feedburner

  • I’ve tested WP-Super Cache on both a Redhat 4 and 5 OS, and on the current 2.3.3 WordPress. I’ve tried both ATOM, and RSS delivery to Feedburner, and have no problem at all with WP-Cache, but once WP-Super Cache is installed suddenly the news feed won’t work in IE or Omega Pro 2.2 news feed reader. In Omega I get the error:

    Reference to undeclared entity ‘rsquo’. Lin 91, position 696.

    I’ve also noticed my traffic from Google declines as well, even though using the mod-rewrite isn’t supposed to have an SEO impact.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Do you have compression turned on? RedHat based installs have problems with that because of a bug with the mime types.

    Also, check your supercache directory – is /feed/ cached? It shouldn’t be.

    When you view your feed url (turn off any feedburner redirection plugins), what is the mime type of the page?

    I also do have problems with feedburners feedsmith plugin. It looks like sometimes after activating wp supercache it doesn’t redirect to feedburner correctly.

    using the latest supercache version.

    Any idea what’s up there?

    Frank

    I’m seeing similar issues. /feed/ is not cached.

    You can see the details of what I cache and what isn’t here:

    http://wordpress.org/support/topic/166793?replies=10

    it looks like supercache (and also wpcache) delivers the frontpage some times when calling /feed/ – this is independent from feedburner. It seem to deliver the feed incorrect.

    Why does supercache deliver my frontpage when you click to subscribe? The feedburner address is in the URL bar, but my homepage is displayed.

    I’m getting really frustrated with this. Please help!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WP Super Cache Messes Up Feedburner’ is closed to new replies.