WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache killed my site (46 posts)

  1. fluentdesigns
    Member
    Posted 6 years ago #

    After installing WP Super Cache it said my wp-content folder wasnt writeable. So I fixed that. After that it killed my site. I can no longer get my site to work, but the admin is working. I go into the plugins folder and i get red error messages saying plugins deactivated due to an error. So I removed the plugin and all the files and still nothing. White blank page.

    Please any help would be great!

  2. Donncha O Caoimh
    Member
    Posted 6 years ago #

    Check your error log. Also remove the line "define('WP_CACHE', true);" from your wp-config.php

  3. fluentdesigns
    Member
    Posted 6 years ago #

    already removed for wp-config.php

    My plugins page is still empty with no plugins now.

    Not sure which error log to view. Sites been down for almost 4 hours and I dont know what to do. :(

  4. fluentdesigns
    Member
    Posted 6 years ago #

    Anyone have any suggestions on how I can get my site back? My site is still a blank white page and I am at a lost on how to get this fixed. Any help please?

  5. Donncha O Caoimh
    Member
    Posted 6 years ago #

    Have you tried everything in the troubleshooting section of the readme?

  6. fluentdesigns
    Member
    Posted 6 years ago #

    Yes, ive even removed the site from my server and restored a backup from my weekly backup. Still nothing

  7. maks23
    Member
    Posted 6 years ago #

    This JUST happened to me.

    Site is gone. Can't do anything. Not impressed.

    I followed all steps and soon as I did exactly what you did...voila dead!

    I need this my site up...I have advertisers.

    HELP!!!!

  8. fluentdesigns
    Member
    Posted 6 years ago #

    jlolee if you figure out how to fix this please let me know and I will do that same.

  9. If it's really a wp-super-cache problem:

    Make a fresh backup of your installation (I'm not kidding) and delete the following

    wp-content/advanced-cache.php (this should be a symlink)
    wp-content/wp-cache-config.php
    wp-content/plugins/wp-super-cache (the plugin directory)
    wp-content/cache/wp-cache*
    wp-content/cache/supercache (also a directory)

    Now in your wp-config.php (MAKE ANOTHER BACKUP) edit the file and remove the line that says this:

    define('WP_CACHE', true); //Added by WP-Cache Manager

    Now make a backup of your .htaccess file. Remove the lines that looks something like this:

    # BEGIN WPSuperCache
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    AddDefaultCharset UTF-8
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !=POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{DOCUMENT_ROOT}/blog/wp-content/cache/supercache/%{HTTP_HOST}/blog/$1/index.html.gz -f
    RewriteRule ^(.*) /blog/wp-content/cache/supercache/%{HTTP_HOST}/blog/$1/index.html.gz [L]
    
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !=POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{DOCUMENT_ROOT}/blog/wp-content/cache/supercache/%{HTTP_HOST}/blog/$1/index.html -f
    RewriteRule ^(.*) /blog/wp-content/cache/supercache/%{HTTP_HOST}/blog/$1/index.html [L]
    </IfModule>
    
    # END WPSuperCache

    After that's done try accessing your blog. If it makes it worse, restore the full backup I said to make in the beginning.

    As Donncha said, you also need to look at your error_log file that your web server creates. If you are on a hosted environment, ask your provider for that file.

  10. maks23
    Member
    Posted 6 years ago #

    What a pain....

    I just called Lunarpages to restore from yesterdays backup. I won't be using this plugin. Brutal.

    Not recommended at all.

  11. Don't use it if you don't want to, but it's an awesome plugin when you need it.

    If you can, try to find out what the error was from the log.

    Either way restoring your backup should set you right.

  12. Donncha O Caoimh
    Member
    Posted 6 years ago #

    jdembowski - thanks for the comprehensive run through of files.

    I'd also add, after helping Brian Gardner that checking your .htaccess file may work wonders too.

  13. fluentdesigns
    Member
    Posted 6 years ago #

    Ok so what do I do if I do a backup restore and it my site is still loading a blank page? this is just crazy

  14. Did you delete those files I listed above? And modify .htaccess and wp-config.php?

    If you did then wp-supercache is gone and can't be the problem; the plugin and it's components are no longer on your server. If that's the case, then you need to see your server's error_log file. If you are on a shared host then ask your provider.

    If you only did a restore, please delete those files and modify wp-config and your .htaccess.

  15. Prosenjeet
    Member
    Posted 6 years ago #

    this is for all.....

    This JUST happened to me.
    Site is gone. Can't do anything.

    i had the same problem.
    i did this;

    Now in your wp-config.php (MAKE ANOTHER BACKUP) edit the file and remove the line that says this:
    define('WP_CACHE', true); //Added by WP-Cache Manager

    and it worked and everything became normal....using wp2.7

  16. Prosenjeet
    Member
    Posted 6 years ago #

    Oh yes, forgot to mention...before doing what i wrote in my earlier post...goto your hosting control panel- cpanel- and delete the WP Super Cache folder from the plugins folder

    wp is too good ..

  17. Donncha O Caoimh
    Member
    Posted 6 years ago #

    me.prosenjeet - next time you install it make sure the path in wp-content/advanced-cache.php is correct. That's probably what caused you problems.

  18. Prosenjeet
    Member
    Posted 6 years ago #

    donncha,
    you know what, I didnt select the folder or anything...I saw the plugin, installed it through my dashboard...I didnt change anything it was all done by WP

  19. Prosenjeet
    Member
    Posted 6 years ago #

    UPDATE-
    I just checked the path you said.
    The wp-content/advanced-cache.php reads-
    <?php
    # WP SUPER CACHE 0.8.9.1
    require_once( '/home/pdssite/public_html/wp-content/plugins/wp-super-cache/' . 'wp-cache-phase1.php' );
    ?>
    and the plugin folder was put in the wp-content folder.
    Any reforms you suggest to make this work

  20. raphaelsmp
    Member
    Posted 5 years ago #

    Since I updated my Super Cache to 9.1 everything is screwed up! My categories are now dead and so is my archive list. Also, my email subscribers are getting no images!

    Is anyone else seeing this????

  21. Donncha O Caoimh
    Member
    Posted 5 years ago #

    raphaelsmp - no, what's your permalink structure?

  22. arebos
    Member
    Posted 5 years ago #

    This 500 server error still occured, because the WP Super cache is not completely removed from the system. WP Super cache is still alive in the database, in the option table. Is should be the script write an entry to the table. Delete it and it works for me.

    Try it if you've done what djembowski said above, and then open your database using Phpmyadmin, and browse option table.
    Find the last line of the table or a line which has update_plugins value in its option_name, and then edit this entry.
    In option_value field, find something similar like this one:

    s:27:"wp-super-cache/wp-cache.php";s:5:"0.9.1";

    and remove it!

    Then open your WP admin. If it doesn't works, try to refresh your browser or use another browser.

    It should be done!

  23. Dave333
    Member
    Posted 5 years ago #

    I just got the white screen of death too.

    I uninstalled the plugin and deleted the folder but that didn't help. As others have suggested, you need to remove "define('WP_CACHE', true);" from your wp-config.php

    The hoops you have to jump through to get this plugin to work requires detailed clear installation instructions. I didn't find the instructions clear at all and all the lowering of security on folders concerns me.

    It seems a shame that the author has gone to so much trouble to develop a plugin that many can't use simply, it seems at least, because of lack of clear instrucitons.

  24. thepete
    Member
    Posted 5 years ago #

    From my wp-config, I removed this line:

    define('WP_CACHE', true); //Added by WP-Cache Manager

    and all was fine after that (so far).

  25. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Dave333 - the uninstall instructions say you need to remove the "WP_CACHE define" from wp-config.php ...

  26. CaesarG
    Member
    Posted 5 years ago #

    I am getting the EXACT same problem. I have done everything and still get a white page.

    Terrible plugin.

  27. Donncha O Caoimh
    Member
    Posted 5 years ago #

    CaesarG - follow the "If all else fails" instructions in the readme.txt

  28. CaesarG
    Member
    Posted 5 years ago #

    ^^ I did, it didnt work. I had to reinstall everything from a backup.

    Terrible plugin, I suggest all avoid at all costs and if not BACKUP!

  29. Donncha O Caoimh
    Member
    Posted 5 years ago #

    CaesarG - sorry you had problems, but the plugin works fine on tens of thousands of sites. It's unfortunate you had problems.

  30. Esra
    Member
    Posted 5 years ago #

    Echoing many other frustrated users of this plugin, it killed our site as well. We didn't know the source, so we were practically "down" with a blank page for over 30 hours. When we deleted the extremely flawed WP Super Cache plugin everything went up quickly and beautifully. Though we still wanted to speed up the site so we cleared the cache of the plugin, reactivated and it was fine for a few hours, then the dreaded blank page came back again and the site would only appear with a refresh.

    I lost serious traffic on 2 blogs because of this abusive plugin.

    I'd rather have a slow site than a plugin than having a blank page as often as 3 times a week. Not worth it at all.

    This plugin creates unfortunate experiences. Needs serious tweaking, in the meantime I'm on the search for an alternative. If anyone knows an alternative please let us know as we have lost all hope in this plugin and do not think it can be fixed.

Topic Closed

This topic has been closed to new replies.

About this Topic