Support » Plugin: WP Super Cache » WP Super Cache issue after enabling SSL

  • Resolved rlrouse

    (@rlrouse)


    WP Super Cache was working fine until I enabled SSL on my blog. It still works fine except for one issue.

    With caching set to “On” I get a mixed content warning on the home page. All other pages are fine.

    The WP Super Cache plugin has this option:

    “Send non-secure (non https) request for homepage”

    The box for that option is checked and that seems to be what’s causing the mixed content issue on the home page.

    I can uncheck the box to disable it but it automatically re-checks itself when I click the “Update Status” button.

    Am I doing something wrong or is this a bug in the plugin? Or perhaps there’s some conflict somewhere that prevents this setting from being disabled?

    I appreciate your help. Thanks in advance!

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Donncha Ó Caoimh

    (@donncha)

    This is a late reply, and I see from your site that you’ve fixed this.

    “Send non-secure (non https) request for homepage” is just for the cache tester. It doesn’t change anything in how the plugin caches your site.

    You probably had images or Javascript or something else loading from a http URL that had nothing to do with WP Super Cache..

    cormip

    (@cormip)

    I am experiencing this very issue with version 1.5.9. I get the mixed content warning on my home page only when WPSC is enabled. When I view the source code of the home page with the plugin disabled, every single resource URL is https://. When I enable the plugin, the resource URLs now all show http://.

    CDN is disabled. “Extra homepage checks” enabled or disabled made no difference.

    I’m having the same issues. I changed all occurences of http://example.com to https://example.com and flushed the cache. That didn’t help though.

    I think the problem is that if someone accesses the page using http then the cache caches all resources with http instead of https and then delivers which ever version is currently in the cache.

    Placing this on top of the .htaccess file resolved the problem. This forwards http to https when there is a proxy involved.

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    </IfModule>

    I think the plugin should have a force SSL option.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘WP Super Cache issue after enabling SSL’ is closed to new replies.