Support » Plugin: WP Super Cache » WP Super Cache Experiencing Sudden Problems

  • Hi Doncha,

    As have other users, I too have been experiencing the following error while testing cache in Mod Rewrite mode:

    Fatal error: Cannot use object of type WP_Error as array in /home/mysite/public_html/wp-content/plugins/wp-super-cache/wp-cache.php on line 977

    The pages also fail to be fetched while testing cache.
    While testing & clearing cache I also received the following error:

    Fatal error: Out of memory (allocated 35127296) (tried to allocate 103396 bytes) in /home/mysite/public_html/wp-includes/class-http.php on line 1106
    Also noticed that the “clear cache” button doesn’t always clear all cache, as WPCached files appear after clearing the cache & can only be cleared individually by expanding the cached files window in the Contents tab.
    Tried Legacy mode & the time stamps don’t match, although the pages could be fetched. PHP mode seems to be working…for now. I say for now because the Mod Rewrite mode again began working only to fail shortly thereafter. There was a point when the entire site went down for a few moments, casting the following error:

    “Unable to establish a database connection.”

    Could there be issues with the recent WP upgrade?

    Thank you!

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Donncha O Caoimh


    That fatal error is fixed in the development version. Those cached files might be generated by visitors to your site while the cache is being cleared?

    Hi Doncha,

    Thanks for the reply. I read in another thread where you also suggested to download the dev version but it was said that did not fix the issue. Perhaps this was unique to this person, so if you think the dev version will work, I will give it a try. I assume that I can upload via the WP plugin dashboard?

    In regards to the legacy caching not working, the out of memory warning, & the database connection error? Are these fixed in the new version as well?

    FYI, I noticed these issues when I installed WPTouch & thought there was a compatability issue causing the problems. However, I then learned that others too were experiencing at least one of the same problems, so I assume that I just happen to notice the caching issues because I was looking for them while setting up WPTouch, which I have since deactivated.

    I look forward to your reply & would I benefit by going with your pro version, considering the problems? The site on question is more than a hobby.


    PS-If this dev version is the answer, should I uninstall the current version first, since I won’t be using auto update? Thanks!

    Plugin Author Donncha O Caoimh


    You have to unzip that zip file, and upload the wp-super-cache folder, overwriting the files in wp-content/plugins/

    Plugin Author Donncha O Caoimh


    The memory problems are due to PHP needing more memory. See and look for WP_MEMORY_LIMIT to increase it.

    I’m not sure why some pages aren’t cleared but if you’re getting memory errors maybe the process is stopping before it’s finished.


    The memory happened just after I switched to Legacy caching & hasn’t happened before or since. I switched to Legacy because mod rewrite caching began casting the “977” error. Others have also been experiencing that error as well, yet you don’t think that whatever is going on w/ WPSC might be the cause of the memory errors as well?


    Uploaded the dev theme & mod rewrite still not working. Fetching fails with error “Couldn’t resolve host ‘”. Went back to PHP caching for now.

    Please advise as other users are experiencing the same issue. Again, is there a pro version that might prove more effective? Thanks Doncha.

    Plugin Author Donncha O Caoimh


    Switching to legacy caching has nothing to do with the error on line 977. If the plugin can’t resolve your on your site then that hostname isn’t configured or your server isn’t configured correctly and it’s a job for your hosting support.

    The error on line 977 is fixed in the dev version ( The memory problems are just a result of the plugins you use, including this one. Just increase the memory allocation.

    There is no pro version.

    Hi Doncha,

    Switching to legacy caching has nothing to do with the error on line 977.

    Didn’t think so… I switched to Legacy because mod rewrite began casting a 977 error. “Couldn’t resolve host ‘” was also a message received during this time. Only the PHP mode seems to be working correctly.

    The error on line 977 is fixed in the dev version

    Again, the dev version did not fix the problem for me & many others.

    The memory problems are just a result of the plugins you use, including this one. Just increase the memory allocation.

    I have plenty of memory. The only memory warning I ever received was when the problems w/ WPSC were occurring.

    I appreciate your support & use of your terrific FREE plugin for many years, but many have been experiencing the same problems w/ WPSC in 2012 & the dev version is not helping. Seems that something has gone awry w/ WPSC & its functionality as of late. I know you say that the dev version has addressed the issues, but so many with the same problems say it doesn’t correct. Many also have experienced the problems with the cache not seemingly clearing properly. I hope the issues are corrected soon. I realize that you may not agree, & if I am wrong, I apologize, but me & many others are in the same boat. Thank you much for your efforts Doncha!I will check in for updates, but for now, I needed to uninstall the plugin on the site in question, as 2 of 3 modes weren’t functioning & clearing cache was acting up as well.

    Plugin Author Donncha O Caoimh


    I’m surprised you’re still seeing an error on line 977 of wp-cache.php because that line is now this:

    fclose( $fp );

    In the current stable release it’s the following which caused that error:

    if ( preg_match( ‘/(Cached page generated by WP-Super-Cache on) ([0-9]*-[0-9]*-[0-9]* [0-9]*:[0-9]*:[0-9]*)/’, $page[ ‘body’ ], $matches1 ) &&

    Increasing WP_MEMORY_LIMIT will fix your memory problem.

    Just reporting what’s happening…I am no developer, so I can’t explain why… 🙂

    I will say that WPSC is still working fine on 2 other sites, one w/ the new dev version & one on the older version of WPSC. No issues that I can tell. One of those sites runs Thesis, as does the one with the issues, & one uses another theme.

    Keep in mind that I first noticed the errors just after I installed WPTouch & initially assumed that was somehow causing conflict w/ WPSC. But the problems persisted even after disabling WPT & I saw that many others were experiencing the same problems with WPSC that I was. Also, I figured that you would have said something if in fact WPT & WPSC had compatibility issues that could have caused these sort of issues. I know you have had direct contact w/ the team from WPT based on what I’ve read in various forums & it would seem that there are no compatibility issues. Thanks!

    I have the same problem. It works with PHP caching but not when I switch to mod_rewriting.

    I also got this message

    Fetching fails with error “Couldn’t resolve host ‘”. And it failed when it Fetch the first and second copy.

    I have checked the .htaccess files and it should be alright.


    I’m curious, do you use, or have you ever use the plugin WPTouch?

    Also, have you tried the development version of WP Super Cache as Doncha suggested above?

    Plugin Author Donncha O Caoimh


    jerleung – that was your server that couldn’t resolve that hostname. It’s a configuration issue on your server unfortunately. Not the plugin. Show this message to your hosting support and they’ll be able to configure it correctly.

    Alan A – No, I do not use WPTouch. And I have also tried the development version. And it makes no difference in terms of the problem I encounter.

    Donncha O Caoimh – In fact, I am using hostgator. And I will try to check with them to see what is happening. What I observe is that when I choose mod_rewirting instead of php_caching, I cannot even access the blog pages. All pages, including, posts, pages, index.. return a blank page.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘WP Super Cache Experiencing Sudden Problems’ is closed to new replies.