WordPress.org

Support

Support » Plugins and Hacks » WP Super Cache doesn't serve WP Touch always

WP Super Cache doesn't serve WP Touch always

  • I have the latest versions of WP Super Cache (1.1), WPtouch (1.9.42), and WordPress 3.4.1. When I try to use them together, readers of my blog report that sometimes the desktop version shows on their mobile device (iPhone/Safari), and sometimes the mobile version shows on their desktop (e.g. Macbook Pro). Yes, I have the “WPTouch” plugin enabled in the super cache settings.

    What causes this? Is super cache not respecting user agents? How can I fix it? Also, it appears to be a random problem, and switches back and forth between the two versions depending on the page you are viewing.

    Thanks.

    http://wordpress.org/extend/plugins/wp-super-cache/

Viewing 15 replies - 1 through 15 (of 17 total)
  • I’ve got a similar problem. Using wpsc and wptouch together works over a time, then the layout on desktop machines is corrupt and the mobile devices won’t get the mobile theme any longer.

    I’m glad I’m not the only one.

    technabob

    @technabob

    Did you ever resolve this? I have a similar problem where the mobile client randomly shows the desktop version – but ONLY the home page. I’ve never seen it with any other templat.

    Hesadanza

    @hesadanza

    No, I didn’t resolve it.

    same problem here. Desktop eventually shows mobile. Mobile usually shows mobile on home page, switches to desktop on other pages.

    Even if you exclude mobile user agent?

    … yes, and there is no solution available till now 🙁

    Mobile website is very important for my project. The requests from mobile devices are growing fast.

    Maybe someone has another idea?

    I have tried other mobile plugins and the same thing happened with them. These consisted of Mobile Detector and the mobile app in the Jetpack plugin. I really like WP Super Cache, it is the best caching plugin I’ve used for speed of my site. I’m hoping like many more people here that some sort of fix can happen soon. I think it began with version 1.1, but I’m not sure. I know for certain it worked with the version before that. Take care all.

    Has anyone tried the W3 Total Cache plugin? Is it good?

    I am having the same problem with WP SuperCache and WP Touch.

    To resolve it you essentially have to switch off most of the features of WP SuperCache by only using the Easy mode with caching off.

    The two plugins then work, but you are then losing most of the benefits of WP SuperCache

    This is an issue the developers of both plugins need to resolve.

    Is everyone sure that they didn’t have the “first visit via mobile is desktop” set in wp super cache settings ?

    This allows wptouch to put a slider at the bottom of each page to let visitors turn the mobile site on when they want.

    I have had to turn wptouch off as it has a redirect loop error on the home page, but no any other page.

    For me caching is more important that the mobile site, but really I’d like both to work properly.

    Oh I long for both mobile and caching to be built into wordpress directly !

    No news on this yet? I am not seeing the wptouch mobile slider at the footer after installing WP Super Cache. Mobile device support and wptouch plugin option is enabled.

    I have a similar problem, mobile pages are being shown in my desktop browser…

    Has anyone found an answer? I posted a question earlier today before I noticed this thread.

    I haven’t seen any answer.

    Can but try again for next WP release, next SuperCache release and next WP Touch release.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘WP Super Cache doesn't serve WP Touch always’ is closed to new replies.