Support » Plugins » WP Super Cache & Disqus Issue

  • Resolved mwelch



    Been at this for days!!! Can’t work it out and would REALLY appreciate some help.

    I recently noticed that my homepage ( ) was not showing my comment counts. The only new change at the time was installing the WP Super Cache.

    Here are the steps I took to try to fix it:
    1. deactivated all plugins and reactivate one by one
    2.uninstall, and delete disqus and reinstall
    3. uninstall and delete WP Super Cache

    No success. The odd thing is that this in only occurring on the home page. If you click on the page navi plugin to another page you see the comment counts.

    Did contact Disqus and they asked me:

    Did you change the way your permalinks are structured? One of your links points to this URL:

    While the actual URL of the article is:

    We have to use the same URL where the comments are for this to work.

    I had NOT changed the permalink and don’t even know how he got the url listed above??

    Anyway, hope someone can help me out. Really want to continue to use Disqus as it seems to be the only comment system I can use that allows me to display avatars in the comment area.


Viewing 8 replies - 1 through 8 (of 8 total)
  • FYI…just some additional information.

    Looks like the WP Cache Plugin may have changed my .htaccess file so I re-uploaded my previous file but still not changes with the issue.

    Your homepage is being cached so I presume the comment count is html, not Javascript that can update by itself. Set the expiry time to 60 seconds or something but then you won’t get much benefit from the caching. It’s a trade off.

    Hi Donncha,

    At the moment, I have uninstalled and deleted WP Cache and still having the issue.

    Beyond uninstslling and deleting BOTH plugins

    Than reinstalling just Disqus

    I don’t know what do do.

    Any ideas?

    I presume you mean WP Super Cache, not WP Cache? If that’s not installed then it can’t be the reason why Disqus isn’t working.

    If there are cache files left over after you uninstalled, and you left the mod_rewrite rules in, then my previous reply applies. The page is cached and it’s caching the comment count too. See the readme.txt for a discussion on how to keep parts of a page “dynamic”.

    Well it’s great to know WP Super Cache is not the issue…that way I can install it again. =)

    And sorry if this is a stupid question, but which readme.text are you refering to?

    disqus, wp super cache or wordpress?

    Thanks again for your help donncha!

    OK with the help of the disqus author the problem was resolved. Just in case anyone else has this issue….

    Go to Disqus>>Advanced Options>> enable the ‘Output javascript in footer’ checkbox

    Booyaahh…touchdown! 😉

    Thank you so much for this thread!

    I just installed both WP Super Cache and Disqus comments on my site, and as they are both incredibly awesome I was very disappointed when i discovered a bug between them that disabled Disqus comments from showing up.

    Enabling ‘Output JavaScript in footer’ from advanced options, as mentioned above, took care of that issue.

    Bug fixing this problem took me one google search and about two minutes all-in-all. The power of this community is so effin’ incredible! 😀

    “The power of this community is so effin’ incredible!” LOL … it sure is! So glad it worked out for you. =)

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘WP Super Cache & Disqus Issue’ is closed to new replies.