WP-Super Cache "Developmental" Fatal Error ...Array (3 posts)

  1. Dasha1000
    Posted 5 years ago #

    Just upgraded to Developmental version of super cache. Using most recent version of WP. I'm using Legacy Mode.

    Got this message when i ran a test:
    Cannot use object of type WP_Error as array in .../wp-content/plugins/wp-super-cache/wp-cache.php on line 570

    These are lines 570-572:
    if ( $page[ 'response' ][ 'code' ] != 200 || $page2[ 'response' ][ 'code' ] != 200 ) {
    echo '<p>' . __( 'One or more page requests failed:', 'wp-super-cache' ) . '</p>';
    echo '

    • ' . sprintf( __( 'Page %d: %d (%s)', 'wp-super-cache' ), 1, $page[ 'response' ][ 'code' ], $page[ 'response' ][ 'message' ] ) . '
    • ';

      I had a similar problem with the regular/most current version of Super Cache, but it was line 473. I thought this upgrade would fix the problem, and I guess it did, but it has created another one. I'm sure this is easy to fix though.

      Any thoughts?


    UPDATE 1:

    When I change the setting from legacy to mod mode or PHP mode, i'm getting the following warning:
    Warning: array_key_exists() [function.array-key-exists]: The second argument should be either an array or an object in /wp-content/plugins/wp-super-cache/wp-cache.php on line 1848

    Line 1848 says:
    if ( array_key_exists('fsize', $cache_stats[ 'supercache' ]) )
    $fsize = $cache_stats[ 'supercache' ][ 'fsize' ] / 1024;


    UPDATE 2:
    In the Mod setting, looks like i'm having the Fatal Error line 570 problem again. The Warning...line 1848 problem seems to be gone.

  2. Donncha O Caoimh
    Posted 5 years ago #

    The 1848 warning is harmless but I've fixed it in the dev version. I fixed the WP_Error problem too but the cache tester won't work for you. It should display a warning however, which is more useful!

    Grab the dev version again in about 20 minutes to give it time to update.

  3. Dasha1000
    Posted 5 years ago #

    Thanks! Just installed then new development version and it looks like it is now working like a charm.

Topic Closed

This topic has been closed to new replies.

About this Topic