WordPress.org

Support

Support » Plugins and Hacks » [WP Super Cache] Comments don’t update

[WP Super Cache] Comments don’t update

  • I’ve tried both WP Cache and WP Super Cache but I continually run into the same problem:

    My users will always end up not seeing their comment added when the page reloads after submission.

    It works for awhile, but eventually, it stops. It’s a problem for me because my users comment a lot and when they don’t see it added, they’ll try again, resulting in duplicates.

    Any clues what is going on or how I can fix it? As our traffic grows, I’m needing to use this plugin to keep it quick.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Just an annoying problem for me I guess? 🙂

    I wonder if it’s the comment threading plugin you’re using?

    Well, I am talking about PopCritics.com, which we don’t use any plugins for commenting 😉

    I don’t suppose I could get anymore help on this?

    I really, really need to use this plugin, but if comments don’t update, I’m hosed.

    Is there anyway to make it just manually delete the cached version if someone leaves a comment?

    Where would I have to put that?

    Please help! I am at a loss here and I know I’m not alone.

    I migrated my site (macmagazine.com.br) to Media Temple this week after being unable to run WP-Super Cache at DreamHost (spiked the server) and I just tried running it and, of course, it was a DreamHost problem (sucks!). However, for some reason I’m having this same problem, and I had to disabled it again. Comments don’t show up after posts, and even if I edit a post, it doesn’t update the cache. What’s wrong?

    Same issue here.

    And I have tried to test it on my main blog, which uses the Brians Threaded Comments as well as one of my niche blogs that uses nothing but stock WordPress and just a few plugins…

    I think this is more then one person issue.

    More than a one person problem, but the plugin creator doesn’t seem to want to help solve it I guess.

    I’m just forced not to use it.

    The only other solution I think, is to use Disqus or Intense Debate and their javascript method of external comments, which might work.

    Just going ahead and answering Donncha’s questions from this other thread:

    http://wordpress.org/support/topic/171927?replies=9#post-775744

    – I’m running at a (dv) Rage server at (mt) Media Temple.

    – FastCGI support isn’t enabled.

    – I don’t know about Apache2 with mod_php, probably not.

    – Yes, there are lots of files inside /wp-content/cache/.

    How should I run that command? Where?

    Comment related plugins I use:

    – Akismet
    – Most Commented
    – Official Comments
    – Paged Comments
    – Recent Comments
    – Subscribe To Comments

    Thank you!

    Might as well copy/paste my email reply to Rafael here. Maybe it’ll help others debug their installs:
    ——————————————
    What plugins are you running? Make sure they’re all updated. Search through your plugin directory for the following strings:
    comment_post
    edit_comment
    wp_set_comment_status
    delete_comment

    Those are WP action hooks. If you find them, you need to check if the plugin isn’t doing a die() or wp_die() or exiting. You could also add an error_log() statement in wp-cache-phase2.php in the wp_cache_get_postid_from_comment() function just to see if leaving a comment or editing a post actually calls that function.
    You could also add an error_log in wp_cache_post_change() which does the actual deleting of cached files.

    Hope that helps, use Google to find out about error_log() if you have to.
    ——————————————

    I don’t know if this is the same problem or not. But here goes. It seems there’s a conflict between the original WP comment platform and Intense Debate. If I have comment to be approved, and I do in the wrong order (not that I have figured out what that is) I lose the comments that have been previously approved. This happens on an individual post. So. . .I can still see the comments in my list but they are not showing up on the actual posts once I approve a comment for that particular post.

    For example, earlier today I had 5 comments on my most recent post. Tonight I saw I had a new comment up for approval, so I approved it. So now I should have 6 comments visible, but I don’t. I only have the one comment showing that I just approved. The previous five are no longer showing up on the post even though when I go to the list of my comments in my admin panel everything shows up. I have tried everything to get them to show up. Uninstalling ID does not help. Re-installing ID does not help. Any suggestions? This is really ticking me off.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[WP Super Cache] Comments don’t update’ is closed to new replies.
Skip to toolbar