Support » Plugin: WP Super Cache » WP Super Cache causing problems in WordPress 4.7

  • yngvai

    (@yngvai)


    When I would try to customize my theme, I would get the following error message:

    “Cheatin’ uh? This changeset has already been published and cannot be further modified.”

    This was happening with every single WordPress theme, so it was not a problem with the theme itself.

    I deactivated all plugins and then re-activated one by one, and it turns out that WP Super Cache was causing this issue.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Jamesits

    (@jamesits)

    I got something like this on every of my WordPress 4.7 sites with WP Super Cache enabled:

    Warning: Illegal string offset 'uri' in /var/www/html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 861
    
    Warning: Illegal string offset 'blog_id' in /var/www/html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 862
    
    Warning: Illegal string offset 'post' in /var/www/html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 863
    
    Warning: Illegal string offset 'key' in /var/www/html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 864
    
    Warning: Illegal string offset 'headers' in /var/www/html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 870
    
    Fatal error: Uncaught Error: Cannot use string offset as an array in /var/www/html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php:870 Stack trace: #0 /var/www/html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php(314): wp_cache_shutdown_callback() #1 [internal function]: wp_cache_ob_callback('<!DOCTYPE html>...', 9) #2 /var/www/html/wp-includes/functions.php(3673): ob_end_flush() #3 /var/www/html/wp-includes/class-wp-hook.php(298): wp_ob_end_flush_all('') #4 /var/www/html/wp-includes/class-wp-hook.php(323): WP_Hook->apply_filters('', Array) #5 /var/www/html/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #6 /var/www/html/wp-includes/load.php(670): do_action('shutdown') #7 [internal function]: shutdown_action_hook() #8 {main} thrown in /var/www/html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 870
    

    Seems there are some serious compatibility issues.

    doume

    (@doume)

    Hello,

    @jamesits With my configuration for this plugin (PHP mode, no mobile support, no CDN, no preload and no extension):
    . I have the same last two lines (among others) when testing with the combo PHP7.1.0 + WP4.7 and the cache doesn’t work correctly.
    . I didn’t find problems with the combo PHP7.0.13 + WP4.7 I now use.

    D.

    • This reply was modified 1 year ago by  doume.
    • This reply was modified 1 year ago by  doume.
    Jamesits

    (@jamesits)

    Yes, downgraded to PHP 7.0 and it worked fine. I forgot when I upgrade my Docker image for WP 4.7, PHP is also upgraded. Sorry for this.

    doume

    (@doume)

    According to the github reposetory the problem with PHP 7.1 has been fixed.
    I had a look and it is now available in the development version.

    Edit : development version works on local PHP7.1.0 + WP4.7 server.

    • This reply was modified 12 months ago by  doume.
    • This reply was modified 12 months ago by  doume.
    FolioVision

    (@foliovision)

    Thanks for the fix Doume. We’ll be careful with PHP 7.1 for now.

    To original poster @yngvai: It’s a little tough rolling your own WordPress membership site, without any developer help James Krieger. A little bit of gratitude to those who answered you and solved the issue would not go amiss.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WP Super Cache causing problems in WordPress 4.7’ is closed to new replies.