Support » Plugin: Simple Social Icons » WP Super Cache Causing Blank Icons

  • Resolved foreverlearning

    (@foreverlearning)



    Hi Nick,
    Hope you can provide some guidance on this. My icons are blank when enabling WP Super Cache. I’m using Mod Rewrite and the Amazon CDN. I’ve purged WP Super Cache but seems to not solve the issue. Any suggestions? The url is http://intentionalmagic.com

    Thanks in advance.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Here’s a page with the blank icons.
    http://intentionalmagic.com/digital-marketing-blog/

    @foreverlearning did you ever get any support with this or figure out a solution. We seem to have run into the same issue. Thank you.

    • This reply was modified 1 year, 1 month ago by  lisadavis12.

    I’m sad to say I got zero support Still have blank icons. I’m guessing the developer just doesn’t have the time or desire to support the plug in actively, or this is seen as an issue not worthy of attention.

    I’ll probably try fast cache tomorrow to see if that helps.

    Plugin Support Nick Cernis

    (@modernnerd)

    Sorry to miss this, @foreverlearning.

    My browser console shows this error for your site, which is preventing the icons from loading: Unsafe attempt to load URL http://d3y23jp586fn1.cloudfront.net/wp-content/plugins/simple-social-icons/symbol-defs.svg from frame with URL http://intentionalmagic.com/digital-marketing-blog/. Domains, protocols and ports must match.

    You could exclude the symbol-defs.svg file from being served via your CDN if your plugin/CDN settings offer a way to exclude files by name. That way the SVG containing the icons will load from your own domain at intentionalmagic.com, and the icons will then be visible again.

    @lisadavis12 If this does not solve the issue for you too, please feel free to open a new topic and link to your site. I’d be happy to take a look.

    Hello Nick,
    Thanks for the reply. Much appreciated. I looked through the Amazon CDN/Cfloudfront settings and there does not seem to be a means for excluding a single file. I also looked through the WP+SuperCache Settings and could find no way there as well.

    Plugin Support Nick Cernis

    (@modernnerd)

    @foreverlearning If you configure your CDN via the Super Cache plugin, you could try this:

    1. Visit Settings → WP Super Cache → CDN.
    2. Change the “Exclude if substring” field from the default of .php to .php, symbol-defs.svg (or adjust accordingly if you have other rules there).
    3. Clear your site cache and check the page at http://intentionalmagic.com/digital-marketing-blog/ to see if the icons then appear.

    If you don’t manage your CDN via that plugin (“Enable CDN Support” will be unticked on the CDN tab), you could try contacting your host or CDN provider’s support team to ask how to exclude that file.

    Nick,
    Somehow I missed this field this morning. Maybe not enough coffee. Works just fine. Thank you so much for your attention and support.
    Dan

    Plugin Support Nick Cernis

    (@modernnerd)

    Great to hear that solved it, Dan! Thanks for letting us know.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘WP Super Cache Causing Blank Icons’ is closed to new replies.