WordPress.org

Support

Support » WP-Advanced » WP Super Cache – Caches Category Page Instead of Home Page

WP Super Cache – Caches Category Page Instead of Home Page

  • Sometimes for certain users/browsers WP Super Cache serves the wrong cached page for the home page. Instead of serving the home page it serves a cached version of the first category page. It’s hard to reproduce the problem but we’re seeing it more or less daily.

    Any suggestions?

    Below are the plugins we have installed:
    Akismet 2.2.3
    All in One SEO Pack 1.4.6.16
    Breadcrumb Navigation XT 1.8.0
    Dagon Design Sitemap Generator 3.15
    Robots Meta 3.0.11
    Secure and Accessible PHP Contact Form v.2.0WP B20070213
    SEO Friendly Images 2.3.1
    TinyMCE Advanced 3.2
    Viper’s Video Quicktags 6.1.15
    Wordpress Automatic Upgrade 1.2.2
    WP Super Cache 0.8.8

    David

Viewing 15 replies - 31 through 45 (of 66 total)
  • Bah. My photoblog is using /%postname%/ as it’s permalink structure so the static front page thing doesn’t work.

    Try having your blog use /%category%/%postname%/ as it’s permalink structure… that’s what’s messing all my blogs up. And yes, I have the same issue as everyone else.

    ^^ I have the same permalink structure as you serb.

    I actually disabled the super cache aspect of wp-super cache and I’m running fine. Would like the super cache, but I can live without it.

    CrazySerb – my photoblog is acting up, even with your permalink structure I can’t convince it to use a static front page. Have configured ocaoimh.ie to do it though and it’s been fine for the last 3 hours or so.

    Maybe the advice for anyone suffering with this problem is to use half-on mode. You won’t notice any difference in speed!

    Yeah, I went with half-on and no problems… yet.

    I think we’ve got a trend. I’m using the same /%category%/%postname%/ permalink structure.

    How many people are using half-on mode successfully?

    robreact – that permalink structure is probably it, although I’ve been using it with a static front page on ocaoimh.ie for the last 20 hours or so and it’s been fine. There has to be another mitigating factor.

    Apart from the two above using half-on mode I know another big site using it too and he hasn’t seen any problems. I’ll add a FAQ about this to the docs.

    We’re seeing very similar problems to the ones reported in this thread.

    We have WP Super Cache 0.9

    It’s odd because we haven’t touched it for weeks but over the last two days (5th Aug 2009 – 6th Aug 2009) ‘something’ has been corrupting the generated index.html page every four hours or so. This mangles our home page which is very bad news 🙁

    Actually we’ve had to disable WP Super Cache for now pending some kind of solution.

    If anyone finds a solution we’d be very grateful to hear about it !

    Another point… we had to disable the WP Super Cache compression a while back as well because it seemed to be incompatible with some recent browser updates (or vice versa if you prefer). Is there any solution to this problem also?

    Thanks,
    Brian

    BrianSummers – try the cache in half on mode. That should work better!

    Thanks for your response.

    Before I try that, (I’m nervous because it’s a live system), could you explain why that might help and offer any reason why it was breaking in the full on mode?

    I’ve no idea whether there was a change to the machine I run my system on (eg. some kind of operating system patch update for example) but I don’t think there was… hence I’m really puzzled why this has suddenly started to happen.

    Thanks again.

    I can’t explain why except that it fixes the problem for everyone who tries it. I can’t reproduce the problem on my own servers so I can’t debug it.

    You won’t notice any speed difference in your site though. It’s perfectly safe to do.

    I’m having the same issues as well.. Setting is the half modus fixed the trick, but I have not had this issue for a long time. Yesterday I upgraded to the latest version of WPSC (0.9.6.1)and this morning I discovered the site was only showing the view of the first available category. FWIW.

    I can confirm this issue too, setting the cache to “half mode” helps, but I’m pretty sure that wordpress stats don’t work any more after I activated the “half mode”…

    Thanks for your responses.

    We switched to Half-Mode as suggested and I’m pleased to report that we haven’t had problems all morning.

    However, I’m not sure if we’re seeing any benefits… (?)

    On each page I see at the bottom:

    “Dynamic Page Served (once) in n.nn seconds”

    It seems to be generating the pages every time – it doesn’t appear to be using the cache at all (?)

    On the disk I can see the static html files that were created under my cache directory but these are not being updated… so maybe there is some caching going on here.

    Maybe it is working and I just don’t understand it…

    My RewriteCond rules only refer to the supercache directory not the cache directory above… Should these rules be changed for Half-On mode?

    Thanks.

    mantis108

    @mantis108

    Hi all,

    Wanted to jump in to confirm we are having same experiences as others here with our blog, and the remedies are the same for us — setting to half-mode or leaving it fully on and clearing the cache manually via FTP (which works for a day or two until the problem recurs).

    We will try downgrading to 0.7.1 and see if that helps. If there’s any information we can provide to help diagnose this Donncha let us know, we’d be happy to help as we’d like to run the latest version in full mode!

    Thanks…

Viewing 15 replies - 31 through 45 (of 66 total)
  • The topic ‘WP Super Cache – Caches Category Page Instead of Home Page’ is closed to new replies.