Support » Plugins » WP Super Cache – Buffer is blank – No closing HTML – Not caching – Tried it all!

  • Hi everyone, thanks in advance for reading.

    WP Super Cache simply will not work for me. I’m currently attempting the mod_rewrite method, though PHP and legacy modes have not worked either.

    In my debug file, these two lines keep re-appearing, and I think are what is preventing the plugin from working:

    - Buffer is blank. Output buffer may have been corrupted by another plugin or this is a redirected URL. Look for text 'ob_start' in the files of your plugins directory.
    - No closing html tag. Not caching.

    Apart from this, whenever I do “Test cache” it says my timestamps are different. Also, I’ve never seen the WP Super Cache comments at the end of the HTML of a loaded page – so I’m sure it’s not working.

    I’ve tried reverting back to a default theme and turning off all plug-ins except WP Super Cache. That didn’t work.

    I searched my plugins folder for ‘ob_start’ and found it in my Akismet (anti-spam comment) plugin. But disabling that had no effect. I then searched the rest of my wordpress directory for ‘ob_start’ and found it in several core default WordPress files – but those can’t be causing the problem, at least, I don’t think so.

    I ran the W3C site validator on my site, and it found 20 errors. Possibly this one is related to the “no closing HTML” debug error from WP-Super-Cache?

    <!DOCTYPE html>
    <html xmlns="">
    <html lang="en-US">

    It claims the error is in the line with the “en-US”>

    Am I not allowed to have two HTML tags like that? I’m not even sure how WordPress is generating that.

    I’m really confused and would really like to get this plugin working. I hope that the author sees this and can chime in!

    My site is

    Thanks again!

  • The topic ‘WP Super Cache – Buffer is blank – No closing HTML – Not caching – Tried it all!’ is closed to new replies.