Support » Plugin: WP Super Cache » WP Super Cache broke admin access

  • Hello,

    When trying to access my admin page at http://citius.fr/citiuslogin I land on a blank page.
    If I display source code for the page I get the below error message:

    <!– WP Super Cache is installed but broken. The constant WPCACHEHOME must be set in the file wp-config.php and point at the WP Super Cache plugin directory. –>

    I have tried :
    – Deactivating all plugins
    – Setting define(‘WP_CACHE’, true); to FALSE

    This is the Wp-config line mentioned below. The path does not look like the standard root plugin one but I haven’t changed this…

    define( ‘WPCACHEHOME’, ‘/data/nfs/ftp/00/79/87/root/wp-content/plugins/wp-super-cache/’ ); //Added by WP-Cache Manager

    I am not sure what goes wrong here but would appreciate some help !

    Thanks,

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • G

    (@gnetworkau)

    You should have:
    define(‘WP_CACHE’, true);
    AND correct path for the plugin, similar to:
    define( 'WPCACHEHOME', '/home/user/public_html/wp-content/plugins/wp-super-cache/' );

    You use FTP, just put the correct path to plugin, the one which appears in the address bar of your ftp program.

    Thanks for the quick reply

    I did update the path as shown into my Cyberduck fpt client: /httpdocs/wp-content/plugins/wp-super-cache/
    No change..
    Am I doing something wrong ?

    Prior to this change, the path pointed to: /data/nfs/ftp/00/79/87/root/wp-content/plugins/wp-super-cache/
    Where it seems some WP super cache files are located as well, unsure why/how. This folder contains: advanced-cache.php – a cache folder – dp.php – object-cache.php – a folder upgrade.

    Do you maybe have other ideas on how to fix this ?
    Thanks

    G

    (@gnetworkau)

    I’m surprised you don’t have problems with other plugins too. There is a configuration problem on your server if you have wordpress files in multiple locations. To my knowledge there should be only ONE Document Root, where all your website files are served from.

    If you are using Plesk for server admin, read the following on setting your Document Root, as you should have only one:
    https://docs.plesk.com/en-US/onyx/administrator-guide/web-hosting/website-directory-structure.68695/#o77500

    If you need assistance with that, you should ask your hosting administrator. The problem should disappear and everything work properly.

    Other things to do after fixing Document Root:
    Dashboard > Settings > Permalinks – click “Save Changes” (fixes permalinks)
    Re-activate Supercache
    Add in Supercache settings “strings to not be cached”: /citiuslogin

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘WP Super Cache broke admin access’ is closed to new replies.