WordPress.org

Forums

WP Super Cache and Dreamhost PS (11 posts)

  1. newmed
    Member
    Posted 6 years ago #

    Anyone has succesfully installed WP Super Cache on a Dreamhost Private Server ?
    It doesn't seem to work in my case.

    At first it was working then after a while i noticed a huge spike in memory and a "Page not cached by WP Super Cache. Could not get mutex lock." in the footer so I edited wp-content/wp-cache-config.php and uncommented "$use_flock = true".

    I also noticed that my cache folder had permissions belonging to dhapache so i changed to $cache_path = WP_CONTENT_DIR . '/tmp/';

    Now, WP-Cache seems to cache pages but only when I visit the pages myself. WP-Super-Cache is showing 0 cached pages and 0 expired pages. I'm also not sure expired pages are deleted.

    I'm using WordPress 2.7, WP-Super-Cache 0.8.6

  2. forefront
    Member
    Posted 6 years ago #

    I've no solution but can attest to the fact this happens on regular Dreamhost hosting not just on Private Server.

    I'll run some tests and let you know what I find.

  3. Bonusball
    Member
    Posted 6 years ago #

    I have successfully installed it.

    When I first switched to DH PS, super cache told me that the directory holding the cache was unwritable. So I changed the permissions on the directory to 777 and it's worked fine ever since.

  4. forefront
    Member
    Posted 6 years ago #

    That will/may work but you may still get memory spikes as your directories within your account are on NFS volumes.

    What I found works and had this confirmed with Dreamhost tech. is to write to /tmp/

    However if two DH customers both did that you'd be rewriting each others' .htaccess so I did this in cache config:

    $cache_path = '/tmp/mydomain/';
    $file_prefix = 'wp-cache-mydomain-';

    HTH

  5. Bonusball
    Member
    Posted 6 years ago #

    I want to correct myself here - supercache was not really working, I just thought it was.

    DH has some documentation on it here:
    http://wiki.dreamhost.com/Fine_Tuning_Your_WordPress_Install

    They suggest turning the plugin "Half On." This is really just using wp-cache, and in the same documentation it points out that wp-cache is not recommended! Sure enough, trying this, my server immediately served up a 500 error.

    So I deactivated supercache and installed hypercache instead, and that is working.

    http://www.satollo.com/english/wordpress/hyper-cache

    I never tried your tip, forefront, but hypercache is working fine for me so I will probably leave it that way.

  6. forefront
    Member
    Posted 6 years ago #

    Update from me, too!

    Seting it to /tmp/mydomain/ works BUT files are not being removed on expiry and my /tmp/ folder just filled up and crashed the site and MySQL.

    So I will use Bonusball's suggestion and if that doesn't work, regrettably, find a different web host.

  7. newmed
    Member
    Posted 6 years ago #

    I have finally decied to disable Super-Cache after the 0.9 upgrade. It's still not working. I also installed hypercache to see if it works better.

  8. jadmadi
    Member
    Posted 5 years ago #

    same here, I wonder what's causing the problem

  9. ceefour
    Member
    Posted 5 years ago #

    Anyone tried the steps in http://wiki.dreamhost.com/Installing_WP_Super_Cache ?

    I wonder if it's actually working, and I'm not sure what's wrong. My site often shows a blank page with WP Super Cache. :( Perhaps insufficient memory_limit ?

  10. ceefour
    Member
    Posted 5 years ago #

    Anyone tried the steps in http://wiki.dreamhost.com/Installing_WP_Super_Cache ?

    I wonder if it's actually working, and I'm not sure what's wrong. My site often shows a blank page with WP Super Cache. :( Perhaps insufficient memory_limit ?

  11. ceefour
    Member
    Posted 5 years ago #

    I went with Bonusball's suggestion to use Hyper Cache and it's working fine.

    Perhaps one day I'll try WP Super Cache again (when my site gets too popular perhaps ;-) but for now Hyper Cache does its job perfectly and I'm happy! :)

Topic Closed

This topic has been closed to new replies.

About this Topic