Support » Plugins » WP Stats Displays Post ID # Instead Of Title

  • In WordPress Stats the post’s ID number is displayed under “Top Posts & Pages” instead of the title. This started happening after I upgraded to 2.5.1. Only the posts I published after the upgrade do this. Posts published prior to the upgrade show the title properly.

    Sometimes, if I edit the post, it will display the title after refreshing the Stats. But if I refresh again later, it will go back to displaying the ID#.

    Any ideas?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Are you saving (or auto-saving) drafts without a title? I’m running into where the first title I put on a post is sent to the stats servers. Even if I fix it before publishing. I’m wondering if posts without a title get the ID sent instead. I would think the plugin shouldn’t send the title until the post is published, and/or the stats server would discard old titles.

    That’s an interesting suggestion. Sometimes I don’t enter the title until after composing the post. No doubt it was autosaved.

    Also, like you, I had a post for which I entered the title first, but changed it before I published. On that post Stats would switch between the titles for no reason that I could discern. But that was before I upgraded to WP 2.5.1.

    Both of those scenarios fit your speculation nicely. Does anyone from WP read these forums? Is there a way for you to pass on your ideas to them?

    I’ve seen about 30 ways to contact them, including these forums. However, I’ve seen no indication that anyone official bothers with any of them.

    Thanks haochi, but this is not an idea suggestion. It is a support issue for a problem in the software.

    I’m still having this problem and I just noticed a new wrinkle.

    I started a new post by entering the title. Before I entered it completely, the post was autosaved. Now Stats shows just the portion of the title that was entered at the time it was autosaved.

    This still fits with KingRat’s theory.

    For what it’s worth, I’m seeing the exact same behavior on my blog (2.5.1) …

    This problem is still occurring. Does anyone have an idea what’s going on and whether it will be resolved? Thanks.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘WP Stats Displays Post ID # Instead Of Title’ is closed to new replies.