Support » Plugin: WP Statistics » WP Statistics doesn’t count hits with WP-Rocket active

  • I have both WP-Statistics and WP-Rocket activated. In the WP-Statistics settings i checked “use caching plugin” – but no hits are counted if WP-Rocket is active.

    I’ve also the plugin Disable REST API activated – but I wonder if this cause problems, since WP-Statistics works also with this plugin if WP-Rocket is deactivated.

    Is there any solution for this issue?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Mostafa Soufi

    (@mostafas1990)

    Hi,

    Thank you for reporting, actually, we’ve had a lot of improvement in this section in the beta version which is released in the next version.
    https://github.com/wp-statistics/wp-statistics/tree/development

    That would be great if you make some tests with this version and let us know about the result.

    Hi,

    same problem here.
    I installed when wp rocket is active, wp-statistics is not counting anymore.
    Does anyone have a solution for this?

    KR
    Daniel

    Thread Starter Christoph Letmaier

    (@chrisiwien)

    @mostafas1990: Unfortunately I don’t have time for testing right now.

    @danipmd: from the WP Rocket support team I got this proposed debug workflow:

    1. On the Media tab, uncheck LazyLoad
    2. On the File Optimization tab, uncheck each option, one at a time.
    3. Each time you deactivate an option, check your site in a private/incognito browser window where you’re not logged in as a WordPress user.
    4. Reload the page a couple of times to make sure it’s cached. When the issue resolves, you know it was caused by the last option you disabled.
    5. Once you know the option that causes it, consult this guide for possible fixes:http://docs.wp-rocket.me/article/19-resolving-issues-with-file-optimization

    I did not try that, maybe it helps you.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.