Support » Plugin: WP-Stateless - Google Cloud Storage » WP Stateless & WP Smush

  • Resolved jkohlbach

    (@jkohlbach)


    Hi guys,

    We have been using WP Stateless for a few months and love it. Very handy for pushing all assets to Google Cloud Storage as we’re running multiple stateless servers.

    We’re now looking at using WP Smush alongside WP Stateless but it seems that it isn’t working as expected.

    We’ve confirmed when WP Stateless is NOT in stateless mode WP Smush can do it’s image optimization (including resizing originals, compression etc). But as soon as we turn stateless mode on, it doesn’t work.

    Has anyone used these two plugins together? What is the trick to get them to work nicely?

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author Alim

    (@alimuzzamanalim)

    Try this prerelease version https://github.com/wpCloud/wp-stateless/tree/v2.1-RC-1
    We solved this issue and going to release this soon.
    Please provide your feedback after testing.

    • This reply was modified 1 year, 7 months ago by Alim.

    That’s brilliant, thanks a bunch @alimuzzamanalim.

    We’ll give this a test and report back.

    Plugin Author Alim

    (@alimuzzamanalim)

    Sorry @jkohlbach,
    The changes we made is in the released version. If you have the problem in latest releaseed version then we have to do some testing and fix it. Hoping we would be able to include the fixes in next release.
    The link I gave you was a old one, the latest git tag is 2.1.5-RC1. It’s have fixes for some other image optimization plugins.

    Hi Alim, just to clarify, this new version will allow us to run WP Smush (compress images) AND stateless together?

    So if I upload an image, it will get optimized by WP Smush, THEN, Stateless will remove the original and upload to my google cloud? Thanks!

    • This reply was modified 1 year, 7 months ago by audiowarrior.

    Hi @alimuzzamanalim,

    I have re test using the link you gave, the rc one, issue still persist.

    Yes we found this issue on latest version of WP Stateless. Version 2.1.4.

    We tried using wp smush on a site that have no wp stateless and wp smush optimization works as expected.

    we have set up normally wp stateless, nothing fancy in our set up.

    I’m replying in behalf of @jkohlbach

    Hope this info helps.

    Plugin Author Alim

    (@alimuzzamanalim)

    Sorry for the confusion.
    We have solved the problem for CDN mode but the problem still exist for Stateless mode as you reported.
    Seems our fix only worked for CDN mode. For Stateless mode we are working on it now.

    Hey @alimuzzamanalim,

    Is there a upcoming release which I can test with Smush? Optimised images aren’t synced to bucket even with the latest version. And I think this would be an issue with all the plugins not just Smush.

    Specially if the image is optimised after it is already uploaded to Google Bucket. I happened to debug this and I might have figured out the cause of this.

    Do you have any related github issue? I can continue the discussion over there.

    Cheers, Umesh

    Plugin Author Alim

    (@alimuzzamanalim)

    I just created a GitHub issue https://github.com/wpCloud/wp-stateless/issues/230
    We don’t have a fix yet. The problem is only in Stateless mode?

    Plugin Author Alim

    (@alimuzzamanalim)

    Hello everyone I found it working in Stateless mode in my testing.
    First image is with WP Smush disabled and second one with WP Smush enabled.
    See screenshot here.

    @alimuzzamanalim

    Still not working on our side

    Our config is

    Stateless mode
    File URL Replacement : enabled
    Cache Control : public, max-age=300, must-revalidate
    Delete GCS File : enabled
    Organization : enabled
    Cache Busting : enabled
    latest wp smush, wp stateless and wp

    not sure if those info would help

    I have raised the issue on WP Smush and they said they found an issue on WP Stateless

    here is the link

    https://wordpress.org/support/topic/wp-stateless-compatibility

    Plugin Author Eric Sopp

    (@ideric)

    @umeshsingla would you mind send me an email directly? eric.sopp@usabilitydynamics.com

    We can work on a fix and then share with you for further testing/refinement. Thanks!

    @ideric, I’ve dropped you an email, also commented on Github issue.

    Plugin Author Alim

    (@alimuzzamanalim)

    The problem has been solved and will be release soon.
    Please check our pre-release version from GitHub.
    https://github.com/wpCloud/wp-stateless/releases/tag/2.1.5-RC2
    Thanks everyone for patient.

    @alimuzzamanalim

    Thanks for the effort of taking action, however I just tried the RC2 above and it still not compatible with WP Smush

    I created a fresh WordPress site Install ( 4.9.5 )
    With only WP Smush Active ( Version 2.7.8 )
    Here is the settings of WP Smush
    https://snag.gy/qdTRYy.jpg

    Now I tried uploading an image way over max width and max height (2048)
    After uploading via the media library and checking the image, WP Smush indeed resized the image I uploaded down to the max dimensions

    The Dimension of the image I uploaded is 3840px by 2160px

    Here is the screenshot of the optimized image
    https://snag.gy/jYQy0E.jpg

    Now I installed WP Stateless RC2 from the link you attached above and see if it indeed is compatible with WP Smush

    Here is the settings for WP Stateless
    https://snag.gy/A9Ece8.jpg

    Now I recreated the same steps above, uploaded the same image but still the uploaded image is not resized down to the max dimensions set on WP Smush

    Below is the screenshot of the uploaded image
    https://snag.gy/hfB2Dy.jpg

    As you can see the image is not resized accordingly

    I hope this helps to resolve the issue

    Cheers

    Plugin Contributor MariaKravchenko

    (@mariakravchenko)

    Hello @rymera01

    Did you enable compatibility in Stateless Settings/Compatibility tab?

    Regards.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘WP Stateless & WP Smush’ is closed to new replies.